RCIO firmware update issue

Hey @polina.buriak , sorry I don’t understand what do you mean as I’m not very advanced in programming. However, I have the exact same problem @tp1 had. Followed everything as was instructed and got the same result as @tp1. So please help.

Hi Abdul,

May I ask you to describe your situation in more detail?

Could you share the photos of your setup? Did you check if Navio2 is firmly attached to the RPi?

Hey @polina.buriak,

Yes, I set up the Navio firmly on the RPi. Initially, when I couldn’t update it, it showed the error: Product: It seems that you haven’t booted Ardu Pilot without Navio screwed, or something like that.

I have been trying to solve the problem for a while now. Your help will be much appreciated.

Error Copy:
navio root[1757] WARNING Please check board voltage (0.0V)!


How do you power the Raspberry? You need a 3A USB source.

At the bench, I use a 3.1A out from power bank.

Even if I power it through the battery (3s, 3A lipo), same error is presented.

Any code you want me to run. Is there any solution to this problem?

@natalia.pavlova
@polina.buriak
@tatiana.andreeva
@emlid
Please help, as this has stopped my project.

Hi Abdul,

Have you tried disconnecting everything from your board and using only Navio2?

Could you please change the power source to, for example, USB?

Yes @polina.buriak .


Disconnected everyone and connected the power source to USB, still:

Error:
"pi@navio:~ $ sudo emlidtool ardupilot
2019-09-30 21:55:32 navio root[688] WARNING Please check board voltage (0.0V)!
Updating firmware using /lib/firmware/rcio.fw
Connect: done
Attach: done
100% (100 of 100) |#######################| Elapsed Time: 0:00:03 Time: 0:00:03
Traceback (most recent call last):
File “/usr/local/bin/emlidtool”, line 11, in
sys.exit(main())
File “/usr/local/lib/python3.5/dist-packages/emlid/emlidtool.py”, line 355, in main
emlidtool.parse_args()
File “/usr/local/lib/python3.5/dist-packages/emlid/emlidtool.py”, line 258, in parse_args
getattr(self, args.command)()
File “/usr/local/lib/python3.5/dist-packages/emlid/emlidtool.py”, line 286, in ardupilot
self.func(ardupilot, args)
File “/usr/local/lib/python3.5/dist-packages/emlid/emlidtool.py”, line 333, in func
args.func(args)
File “/usr/local/lib/python3.5/dist-packages/emlid/util/util.py”, line 37, in wrapped
return fn(*args, **kwargs)
File “/usr/local/lib/python3.5/dist-packages/emlid/emlidtool.py”, line 52, in do_ardupilot
main_window.run()
File “/usr/local/lib/python3.5/dist-packages/emlid/ui/mainwindow.py”, line 483, in run
self._window.run()
File “/usr/local/lib/python3.5/dist-packages/urwid/main_loop.py”, line 278, in run
self._run()
File “/usr/local/lib/python3.5/dist-packages/urwid/main_loop.py”, line 376, in _run
self.event_loop.run()
File “/usr/local/lib/python3.5/dist-packages/urwid/main_loop.py”, line 1328, in run
raise self._exc_info0.with_traceback(self._exc_info[2])
File “/usr/lib/python3.5/asyncio/events.py”, line 126, in _run
self._callback(*self._args)
File “/usr/local/lib/python3.5/dist-packages/urwid/raw_display.py”, line 393, in
event_loop, callback, self.get_available_raw_input())
File “/usr/local/lib/python3.5/dist-packages/urwid/raw_display.py”, line 493, in parse_input
callback(processed, processed_codes)
File “/usr/local/lib/python3.5/dist-packages/urwid/main_loop.py”, line 403, in _update
self.process_input(keys)
File “/usr/local/lib/python3.5/dist-packages/urwid/main_loop.py”, line 503, in process_input
k = self._topmost_widget.keypress(self.screen_size, k)
File “/usr/local/lib/python3.5/dist-packages/urwid/container.py”, line 592, in keypress
*self.calculate_padding_filler(size, True)), key)
File “/usr/local/lib/python3.5/dist-packages/urwid/container.py”, line 1587, in keypress
key = self.focus.keypress(tsize, key)
File “/usr/local/lib/python3.5/dist-packages/urwid/container.py”, line 2269, in keypress
key = w.keypress((mc,) + size[1:], key)
File “/usr/local/lib/python3.5/dist-packages/urwid/listbox.py”, line 985, in keypress
key = focus_widget.keypress((maxcol,),key)
File “/usr/local/lib/python3.5/dist-packages/urwid/wimp.py”, line 535, in keypress
self._emit(‘click’)
File “/usr/local/lib/python3.5/dist-packages/urwid/widget.py”, line 463, in _emit
signals.emit_signal(self, name, self, *args)
File “/usr/local/lib/python3.5/dist-packages/urwid/signals.py”, line 264, in emit
result |= self._call_callback(callback, user_arg, user_args, args)
File “/usr/local/lib/python3.5/dist-packages/urwid/signals.py”, line 294, in _call_callback
return bool(callback(*args_to_pass))
File “/usr/local/lib/python3.5/dist-packages/emlid/ui/mainwindow.py”, line 443, in button_press
FirmwareUpdater().update(quiet_update=False, force_update=False)
File “/usr/local/lib/python3.5/dist-packages/emlid/util/util.py”, line 37, in wrapped
return fn(*args, **kwargs)
File “/usr/local/lib/python3.5/dist-packages/emlid/rcio/updater.py”, line 74, in update
self.perform_action(action[0], action[1])
File “/usr/local/lib/python3.5/dist-packages/emlid/rcio/updater.py”, line 122, in perform_action
self.check_status(status, action)
File “/usr/local/lib/python3.5/dist-packages/emlid/rcio/updater.py”, line 153, in check_status
raise UpdateError(‘Cannot update RCIO firmware’)
emlid.util.util.UpdateError: Cannot update RCIO firmware
"

@polina.buriak
Is there a way to return the product. I flashed the original emlid rasbian multiple times and did a lot of diagnostics but didn’t find a solution.

Hi Abdul,

Does this issue remain from scratch? When did you purchase Navio2?

Please run the following commands and share its output with us:

  • sudo emlidtool test
  • dmesg | grep rcio
  • lsmod | grep rcio

Thanks!

@tatiana.andreeva

I’m sorry for the late reply, apparently, my RPi doesn’t connects to the wifi. Let me connect it to another wifi and get that solved, then I will immediately send the response to your code questions.

Yes, the moment I installed Navio 2 it had an error prompting.

I purchased it 7/30/2019; however, I installed and used much later on. Like a few weeks ago.

Hi Abdul,

Please keep us posted. If you meet any issues with connecting Navio2 to another Wi-Fi, let me know.

Tatiana, do you know anything about the following error? I cannot seem to connect it to Wifi regardless of what I do, the ip-address doesn’t appear on ip finder.

https://photos.google.com/share/AF1QipP_dqC-u6BgRn9_BI7mPhgLtlg3cedXfq3pzFCvKBc1WM4SJPMVq7yZLPjo86xBoQ/photo/AF1QipMI2tJ86ZUqEPGzX8B0PeM0jYbDxCx4224c5x_i?key=R3p4TUtfVmdiRFVua2NLYkJEREc5OG5WQUNOWEN3

Hi Abdul,

May I ask you to reflash your SD card? You can check this guide to find out how.

Please, if possible, try using another SD card.

Ok will do that today Polina.

So I went to CVS bought a new SD Card, re flashed Rasbian img from the Emlid web; however, it still doesn’t appear in my advanced ip scanner. Any help would be greatly appreciated. Is my RPi broken?

https://photos.google.com/share/AF1QipNaANJsRCxO1oKJoyN_6N8pHtr0eCk79evEMTEUZAHWMSW_z3Zh1p4F_yMsrVuxSQ/photo/AF1QipO2tSbbGW9o5KylVfAiWz7mmIzbBkooOqwedrd1?key=dDJHZzRzZEFJSGZzQzFkR01hZ2FkMzFfUDZ4TFpn

Hi Abdul,

May I ask you to share your wpa_supplicant.conf file with me in PM?

Will it be possible to test with another Raspberry PI?

Done