[RCInput_Navio2]: failed to open channels error on latest ardupilot on diy drones repository

While building the latest from DIY drones repository it builds ok but when I run i get the error “[RCInput_Navio2]: failed to open channels”

any ideas?

Can confirm - same here.

The number of RCInput channels has been increased in the upstream. In order to support that you need to sudo apt-get update && sudo apt-get upgrade to upgrade the underlying Linux kernel module.

I tried but it says 0 installed, 0 updated and 0 removed. Will get a screenshot later today

I tried also (sudo apt-get update && sudo apt-get upgrade) then I rebuilt and it does not work for me,
still the same error message “[RCInput_Navio2]: failed to open channels”.

Hello guys, I’m sorry the instructions haven’t worked the way I’d been thinking they would. In order to look into the problem I may need some more information. Coud you please post the output of uname -a, ls /usr/src, apt-cache showpkg rcio-dkms and apt-cache showpkg apm?

I will try today when I get home. George, since 3.4rc1 released I started fresh. New image on SD card with Emlid latest image of course, ran update and upgrade and cloned 3.4 like the instructions and it worked.


I glad, it’s worked eventually. But as I’ve said before, there was no need to reflash SD card :slight_smile: Either way, I’m closing the thread, then. Good luck with ongoing testing!