Raspberry Pi 4 8gb

Hello,

I just received my Navio 2 today and am planning on getting a new RPi4. Will the 8gb version work with the navio and emlid version of Raspbian? Thanks in advance,

Rpi4 2 and 4Gb are ok.

Rpi4 8Gb doesn’t work: https://community.emlid.com/t/the-new-rpi4-8-gig-and-navio-image-not-working/20161

Hi @carrolp4,

I’m afraid Navio2 doesn’t work with RPi 4 8GB currently. We’re now getting this board to reproduce the issue with incompatibility between them and provide a new working image. I’ll inform you once we release it.

Thanks to both posters for the quick response.

1 Like

I am waiting for solution too.

I have the same problem. Navio2 is not booting on my Pi4 8GB. it’s working fine on my Pi3A+. I really need Navio2 on Pi4 8GB as Pi3 is not powerful enough for my application.

Hi Sairam,

We’re working on a new image with RPi 4 8Gb support.

At the moment, I can provide you with a workaround on how to make them work together:

  • Insert the SD card with our latest image into your RPi 3A+
  • Run the following commands:
sudo apt update
sudo apt upgrade
  • Once the update is completed, you can use this SD card and Navio2 with RPi 4 8Gb

Please let me know if it works for you.

Hi Tatiana,

Thanks for the workaround. I tried it and it worked.
Now I can boot that SD card on my Pi 4 8GB.

Thanks again.

2 Likes

Hi tatiana

i tried this as well and it look its like pi4 boots up to navio login screen but none of the usb ports work. This means i cant use keyboard/mouse or anything that interfaces via usb ports.Please Help

Hi @asadali4651,

Thank you for letting us know about it. We’re working on the solution now. I get back once I have any news or additional questions.

Hello Tatiana. My problem is following. I’ve already bought and got several Navio2 boards for my research. And now due to uncertainty with new image for 8Gb Raspberry i don’t know which Raspberry i should buy in order to get down to my work as soon as possible. Is that possible to say within what time interval a new image will be done? Because if it’s a long story, i would prefer to start work on 4Gb Raspberry. What would you suggest?
Thank you.

4Gb Raspberry 4 is fine. My Navio2 configuration is OK with it.

i was able to boot and ssh into rpi4-8gb but none of the usb ports are working. i then tried running dmesg command and this came up. i don’t know if its any help but just wanted to share and help debugging if possible.

Marc, thank you for confirmation about Raspberry 4GB.

Hey there,

A new image with RPi 4 8GB support is out. Check this thread for more details:

It’d be great to get your feedback on how it works.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.