Radio calibration no signal

Hello all,
I have a problem on Mission Planner, I have connected my drone and radio system correctly and I am trying to do radio calibration but there is no signal on mission planner and I stuck at this point. Any help will appreciate thanks.

if its correctly connected and the receiver is funktional there should be signal
not enought information to help you, sorry

i assume you found the settings to enable ppm ?!
https://quadmeup.com/ppm-signal-support-for-fs-i6-radio/

1 Like

yes sir enabled ppm :frowning:

need more info:
you need to explain in more detail which steps did you take already to find the error
how is you receiver connected (e.g. pictures and/or schematics)
which steps of the first time setup did you already do ?
what drone did you built?
how are you connected to your drone ?
is there something that is actually working ?
etc…

1 Like

I have connected my drone and radio system correctly and I am trying to do radio calibration but there is no signal on mission planner and yes enable ppm. i maked accel calibration and compass calibration. But i am trying radio calibration but there is no signal. Please help me.

@igor.vereninov @mikhail.avkhimenia @george.staroselskiy man please help me i have a rasp pi 2, navio2 flyskyi6 and fs-ia6b but i cant see radio signal

Hello.
Could you please post the output of sudo update-alternatives --display arducopter?

1 Like

Hello :slight_smile:

why?? help me

Could you please post the output of cat /sys/kernel/rcio/rcin/ch2?

I have a similar problem. I just upgraded my drone to the latest image and I don’t see any RC signals coming in to QGControl. Also, I see Throttle below failsafe messages in mavlink.

cat /sys/kernel/rcio/rcin/ch2 changes according to my throttle inputs.
Also, sudo update-alternatives --display arducopter shows a correctly selected Navio2 quad-copter configuration.

Any suggestions about next steps of investigation?

That’s strange. Could you please upload your SD card image anywhere for us to look into?

Could you please also try using mavproxy and verify that RC inputs are not transmitted to the GCS?

Hi everyone! Thanks for all comment. I’ve fixed my problem last week. It was about broken bottom and top board connection due to pins. I’ve press and hold the top board down to bottom and then it worked at all. :slight_smile:

Found what the problem was. I configured arducopter to send telemetry to udp:127.0.0.1:14550, I think used mavproxy to send that out to my GCS using udpbcast:192.168.1.255:14550

The clashing of the ports seems to cause problems. I changed my out port to 14555 and was able to see my RC signals.

Now just have to deal with my inconsistent compass issues after compass calibration. Has that ever been caused by importing old parameters from a previous version?

the internal compass is not reliable, never was, never will be. same problems was with an older version of APM and
same for mikrokopter (and a couple of others), to much interference i assume, thats why they all moved to an external compass, far away form the electronics and motor cables (unless they are shielded, or at least twisted).
I didnt find any other way, now its works 100%

I was resigning myself to the fact I’d need to buy an external compass before I even had these upgrade problems. Can you suggest a good one that works well with Navio 2?

hmc5983 is a good option if you need an external compass;

inconsistent compasses while using only navio’s internal compasses is either due to bad or missing compass calibration or magnetic interference;
since only 1 compass is used for navigation at the moment, you can disable the second compass and calibrate compass again; (always reboot after calibration and disabling/enabling compasses)

don’t plave navio to near to other metals/escs/motors for best results;

im using this one:
http://www.ebay.de/itm/172333307490?_trksid=p2060353.m1438.l2649&ssPageName=STRK%3AMEBIDX%3AIT

Dont forget to disable the other two compasses :wink:
and reboot is needed after calibration