Problems connecting to Navio+

Dear friends
I have tried to connect my Navio+ to a pc …

Regarding APM i manage to do this within wifi but when i want to connect through internet with two different connections I fail.

I have tried
sudo ArduCopter-quad -A udp:
sudo ArduCopter-quad -A udp:
even typed ddns address like …
sudo ArduCopter-quad -A

but nothing works

I made a port forward in my router (14550) to my local pc tcp_ip but still no work

The same stands for gstreamer :frowning2:

Also external gps (the one from original pixhawk) doesn’t seem to work … (i dont have navio proper antenna)

for this case for wifi connection i type:
sudo ArduCopter-quad -B udp: /dev/ttyAMA0
and in my SSH console it starts typing stuff continuesly

I have been stragling with it for a week now. I haven’t found any examples that have to do with internet connections. Only WIFI and this is not good to me.

Please … if my pc is " " and my pi is “” can someone give me the command to transmit and receive video and apm from pi to pc ?

Thx in advance … Yiannis

1 Like

Well, for the WIFI with external GPS, try sudo ArduCopter-quad -A udp: -B /dev/ttyAMA0 >

Also, make sure to turn off serial console in raspi-config, that should clean up the garbage coming across on the SSH console.

If you forwarded TCP instead of UDP in your router, it will not work. Most routers I worked with, allow you to select the protocol.

It also depends how your ISP handles IPv4 addresses. Since technically there are no more free public IPv4 addresses, ISPs may use some kind of NAT in there network (Like it is done for mobile connections). That means, the public IP you get from your ISP may be shared with other users.
If your ISP already uses IPv6, the above is most certainly true for your IPv4 address.

ty for your answers jlrogers2 and schuermannsebastian .so is there a way to communicate through internet with mp and gtreamer ? I don’t care if its tcp or udp

To give you any further advice, you must first establish, which of the assumptions I made are true. Do you have a fully qualified public IPv4 address?
If so, did you forward the right protocol in your router?
If in doubt about the protocol, look if your router allows to forward both protocols.
What type of connection do you use for your RPi?

for start i use two differend adsl lines (one for pc and one for pi). Port forward supports both tcp and udp. Regarding full IPv4 I m not sure if its dedicated or not

when i try to run

sudo ArduCopter-quad -A udp: -B /dev/ttyAMA0

i get No INS backends available as a reply

now i got Argument not valid

when i gave sudo ArduCopter-quad -A udp: -B /dev/ttyAMA0

… No Ins backends available


If i omit -A and I only type

sudo ArduCopter-quad udp: -B /dev/ttyAMA0

it doesn’t crush but I still see stuff on my SSH console even though i disabled serial through the raspi-config menu

and can’t connect to mp on my pc

If you get No INS backend available, restart the RPi.
And you can not just leave out the -A and give an IP address.
Telemetry output to the console is APMs way to handle an invalid/missing telemetry option. Even if you leave out the -A option and only use -C, you get an output to the console.

INS was a pi matter indeed … now it works … but when i give

sudo ArduCopter-quad -A udp:…:14550 -B /dev/ttyAMA0

I get Raspberry Pi 2 with BCM2709!
Argument is not valid. Fallback to console
Launch with --help to see an example

mission planner connects to navio+ but GPSstatus2 =0 and never get a lock

what argument is wrong ? by the way i use pi3

ty for your time again

Funny … I removed the pixhawk gps and plugged a ublox 6T on usb.
then typed sudo ArduCopter-quad -A udp: -B /dev/ttyACM0

and everything worked. I could see my position on Mission planner. The only problem was that I could not see hdop and satellites number. How can i fix it ? I think there is a problem with ttyAMA0 option for gps (unless i m doiing something wrong.)

so -B /dev/ttyACM0 works fine but -B /dev/ttyAMA0 returns Argument is not valid

The -B option is meant for only using the external GPS. It disables the onboard GPS. If you want to use both, use the -E option.
On my rover, the -B option works fine with /dev/ttyAMA0.
I never saw the “argument invalid” message before.

Yes I know … but since I don’t have the antenna with mcx connection to connect to the navio gps , I am forced to use another gps from pixhawk that i have. As for the invalide argument message I wonder why i get this

You wrote gpsstatus2=0, but with the -B option your external GPS would be GPS1

You 're right. but also gpsstatus=0

How many wires do you use to connect the Pixhawk GPS to the Navios UART port? You only need four, the other two are GPIO pins. Connecting all six wires can mess up the connection.
The pins are labelled on the underside of the Navio.

I have tried both the original pixhawk gps with the 6 cables , and another external M8N ublox that is compatible with pixhawk (and works well on it) but has only 4 cables . None of those gpss work :frowning: