Problem with flashing Reachview V2


I try to install the new Reachview v2

I look into the help:
So I downloaded and installed the intel utility. This util wants 2 (!!!) usb cables to the Intel Edison but there is only one usb connector on the reach module…
What I am doing wrong?

I then tried to use the terminal mode of flashing the reach module:
installed intel Edision driver and start CMD.exe. Run flashall.bat and got an error that DFU-util is not found!!
What I am doing wrong?

please help!



i managed to get a dfu-util.exe file from
So i did:
unplug reach
start flash all
replug reach

after some time i got an error message:
Dfu device not found Timeout
Did you plug and reboot your board?
If yes, please try a recovery by calling this script with the --recovery option

What do i make wrong?


Hi Franz,
I had similar problems and I have posted elsewhere in this forum about my experience.

In summary:
I only used the Intel GUI to install the drivers after that it is better to use the flashall script (flashall.bat/ from a command line. It shows much better progress reports and will indicate if anything failed more clearly.

Try different USB cables. I though I had good cables, I had used them many times for flashing other devices, but it consistently failed so I started using a short cable supplied with another product and it worked.

The USB port may also be a factor. Try different ports or even a different computer.

1 Like

Hi, where can I find the reachview v2 image to reflash, I cant find where to update in v1.2

Look at this post, please.

1 Like