Problem connecting RS2+ Base to DJI M3E

I have an Emlid Reach RS2+ Base that I use to provide RTK to my M3E. Initially, I was able to use the Reach for corrections and things were working. I had a lot of issues connecting to the Reach’s Hotspot. Now I can connect to the Reach’s hotspot , but I can not get the Pilot app to do anything with the RTK input. When I enter the RTK settings and press Save I get the same messages: “Settings Failed”. This goes away and then it says in red letters “Connecting or not Connected” And that is it. I now can not get any corrections what so ever to M3E. I have check all my settings ad nauseum. My updates are current for both RS2+ and M3E. I setup theRS2+ with the hotspot which I connect to with the DJI RC Pro controller. Shows connected when looking a the RC’s WiFi settings. Output setting is Local NTRIP setting for the RS2+. Any ideas on how to solve this problem would be greatly appreciated! Thanks in Advance!


You’re connecting the RC directly to the receiver? Have you tried forgetting and re-authenticating with it? I usually network the two with my phone hotspot or a router. I found a dedicated networking device to be more reliable.

I’ve had lots of problems with this combination too ( Get a RTK signal Weak. Move to an open area for takeoff or turn off RTK (0x16100066) error message on the DJI RC Pro). I see another forum member posted previously having the same problem.
Like you, my RC Pro was connected to the Emlid with wifi, so it didnt make sense. The previous poster did mention to change your ntrip details to the same as shown in the info section under your Base output.
This seemed to do the trick, you need to reboot the drone as well. I haven’t flown the drone yet, was only trying to troubleshoot at home, hopefully it logs correctly, I’m still a newbie. I don’t understand if I set a Cors stn to my emlid why do i put in a different ntrip to my RC. I presume the ntrip corrections are still relayed through properly.

LightTunnelProd, Sounds like we are kind of in the same boat trying to get this combination working. I also am at my home sorting this out before I go out into the field. I am also a newbie. So from what I understand so far, you need corrections for the satellite signals for each receiver. I am sure that you know this, when you hook up the base and get NTRIP signals you are correcting for the Base’s GPS Error. The way any of these calculations to correct for error is to take an average. This is why the longer the Receiver is able to acquire signals the larger the data base is to use for averaging the more theoretically it is to be close to accurate. The Baseline distance matters. The distance from the Base to the rover has its own set of errors and what ever you can do to minimize that distance reduces that error. So if you are able to get a Base position established through a CORS station with a long data acquisition time it will be theoretically accurate. The small distance of the Reach Base to the Drone normally has very little error. This is why they say that a Reach Base to a Rover is centimeter accurate relative to each other , but only absolute accuracy to how well you set up the bases position. To get back to your question, the corrections from the CORS station is only for the Base to correct itself. Once the Base knows its position, Fix solution, it relays its position correction to the Rover. I am not sure if you are using the Local NTRIP setting in outputs? This is the Port that is used to send corrections from the Base to the Rover. My Question is that the acquisition time that you set under the Base settings in Emlid Flow, is that the time that it uses to average out for the Base’s position calculations? Anybody reading this that can verify my assumptions, I would appreciate any corrections. I don’t want to find out that this was all BS like I did when I found out Santa didn’t exist in my forties’. :astonished:

1 Like

Hey MichaelL, Yes, I am connecting directly from the RS2+ to the RC using the Hotspot WiFi. I have recycled the the Custom RTK Network settings in the DJI Pilot 2 App several times to no avail. I guess I will try using my phone’s hotspot and see what happens. Thanks for your help!

1 Like

The averaging time in base settings is the amount of time that it averages (in a FIX condition if specified) to collect the base point. That’s it. It will not continue to average. It will start the average process again if you tell it to do so, but it will not do it on it’s own.


Your NTRIP settings on the RC must match the Local NTRIP settings, specified by tapping the info button next to local NTRIP on the Reach, exactly. One character off and it will not work at all.
Very specific. And, if you reboot the Reach unit, the IP for local NTRIP output will change, so you have to look at the info screen again and make any adjustments to the setting on the RC. There are no compromises, it has to be perfect.


IMO it’s latency and if you get slightly too far away from the receiver it will act up. Having my phone in between increases that range and a decent Wi-Fi router is even better. A Wi-Fi router with data service is the ultimate in my scenario.


Cheers Dave
Appreciate it

thanks John
that makes sense actually

Did you guys resolve this problem? I’m having the same issue.

Hi @jaybro130,

Sorry for the silence here. I noticed you’ve gotten a lot of input from Michael in this thread. Have you found a solution to your issue? Do you have any further questions?

1 Like

Thanks for checking in on this. I’ve figured out how finicky the M3E can be connecting. But with help from Joe Douglas from E38, I’m getting good connections. Thanks!


Hi Jay. ALL of the RTK drones are very finicky! One character off, and it’s a no-go. And they won’t tell you what the problem is, so it can be frustrating… Welcome to the current state of RTK!


Hello all.

I have M3E and rs2. Normally I’ll set the RS2 up on a monument and use the manual coord input and local Ntrip out. I used my iPhone as the hotspot and it worked fine.

I recently upgraded to a Samsung s23. When using the manual coord it works fine. So today I had to set up somewhere with no monuments and used Ntrip for corrections. That part worked fine however when I went to use local ntrip, I put in the ip address exactly as shown and I kept getting a save error on the RC and no rtk. Oh and everything was connected to the Samsung hotspot.

So I changed it back to no ntrip corrections and got the non Samsung hotspot ip address back and it worked fine.

While using the iPhone either getting corrections or not it works. So not sure if it has something to do with the Samsung. Both are set to 2.4ghz band.

I hope this makes sense. Thanks for any help.

Hi Patrick,

Welcome to our community!

Do I understand correctly that you used an NTRIP service to average your Reach RS2 in fix, saved the coordinates, and tried to use the Local NTRIP option to send the correction to your drone?

Could you please setup everything in the same way and send me some screenshots of the error message on the drone’s controller and some others from Emlid Flow? The Correction Input, Base output and the Wi-Fi tab would be great! Also, please double check if your unit is on the latest firmware (31.8) and if you use the latest version of Emlid Flow (9.11).

1 Like

Did you change the port as well?

So here is what I usually do.

Setup RS2 on surveyor mark with known coordinates
Emlid base set to manual coordinates - enter coordinates
Corrections - Off
Local NTRIP - broadcast
Turn on wifi hotspot through iPhone
Change RS2 from hotspot mode to wifi mode and connect to iPhone hotspot
Connect M3E to iPhone wifi and enter RS2 local NTRIP data
Successful RTK

New Phone -Samsung S23 (Android)
Setup RS2 in random location
Base setup to avg fix - avg 5 minutes
Connect to local NTRIP service for corrections
Base acheives fix
Set local NTRIP broadcast
Turn on phone hotspot and connect all devices
New ip address for Local Ntrip
Enter new ip into M3E
Save Failed no rtk. Ensure you are still subscribed - make sure you are connected etc errors

Change some settings troubleshoot.
Turn off NTRIP Corrections
Turn off local NTRIP broadcast
Connect RC to RS2 base (different IP address again but this IP address is the same IP as the iPhone IP address)
RTK Success but errors are high because no corrections and base is in single mode not fix.

I need to see if my Samsung hotspot setting need to be changed. I changed it from 5Ghz to 2.4 because the RS2 didn’t see it in 5Ghz.

Can you change the port on the RS2 base? it is set to whatever the default is 2001 2100 2101 or something like that. I havent changed it. The only that changed was the ip address when i went from iphone to samsung. it looks like while on the iphone hotspot, the RS2 broadcast its own ip address but while on the samsung hotspot the base changed to a whole different ip address.

I have not updated the RS2 or Emlid flow. I don’t think that is the issue because it still works with the iphone but not the samsung. However, if the update adds compatability with newer phones, that might be the issue.