PPK with cors

I’m trying Post processing with cors. No result. When I try check the sat vis, the results is no obs data. How to use rinex from CORS for PPK? @igorvereninov @TB_RTK @egor.fedorov
Thank you

Do you have log to upload. Or im me to test


I generally don’t have any problem with CORS & local base stations. Most of the problems I encounter are from using wrong RINEX version and the base station specification. I have had to experiment to find right setups. One subtle problem is specifying a base location that is outside the error limits for X,Y, or Z. If the RINEX base station location is used, I usually don’t have much of a problem. If you specify a base station location outside of the Rover Single error limits, the data point will be thrown out and you will not have any data points to use in RTK. (I don’t recall if this applies to the first BASE data point killing the whole RTKPOST process, but I think it does.)

I had to do a lot of trial and error to find some of the causes. Check Rinex versions. Also, sometimes, I have input wrong date/time.

Also, sometimes I get no Sat Vis for BASE although RTKPOST and plot work fine. Receiver location may affect Sat Vis in RTKPLOT. Check this for your location.

Bottom Line: Had to experiment a lot to weed out setup problems. Once you find proper setup, usually things work out OK, but RTKPLOT still has a few bugs in plotting satellites, etc.

Good Luck…

This is not RTKPOST, but Canadian PPP Worldwide L1 does not accept RINEX version greater than 2.11. Most CORS stations here in US are GPS only with RINEX 2.11 .

I see TB_RTK has responded while I was writing this. You should get some more insight…

Me :flushed:

1 Like

Thank you, this is the file download of my rover and base CORS


This is what i got out it at first. Some tweeking might give better fix.
Just convert raw from rover to .obs and ad refrence file as base.

1 Like

Awesome. Would you kind teach me to do that.
What kind of rinex should I convert, 2 or 3. And what about the rtkpost setting.

Stock config, more or less. Rinex 3 i think i used

Message: no position in rinex header.

Would you sent me the .conf file?

Dicky1.zip (1.4 KB)

What’s wrong??

Sorry, @TB_RTK, I have no more idea. Would you kind to sent me rtklib that you use to process it.

I suspect the rinex is not set correct for obs or the base file
But here is the files i used

This is my rtkconv for converting rover

What the meaning of rinex base is not set correctly?

I use these files to, but still no header position.

I thought you may have tried converting the base file.

Hmm, Funky strange

But thank you very much for your help, post processed my files. Really helpful. I will use that pos file for geotag my aerial mapping photos.
Thank you

1 Like

What size is the file you used for base?


I tried the files from post #5 and #12 and got exactly the same problem as @dicky using ‘RTKPOST 2.4.3 Emlid b27’ (latest download) and RINEX 2.1.

I am running b26.
RTKLIB 2.4.3.b26

Thank you for ‘b26’ !

I tried it and get funny results. Using ALL your files (b26, conf, etc.) I still get the same error.
But when I enter the coordinates from your screen shots manually in LLH deg, the b26 and b27 run but Q=0 and no output solution. Switching back to Rinex header the b26 gets a Q=2 solution that looks exactly like your pictures, the b27 insists on ‘error: no position in rinex header’ and therefore no output.