Pixhawk Integration issue - protocol NMEA

Hello together,

I am trying to integrate my Pixhawk Black Cube with a Reach M+ unit. Additionally, I use the RFD900 radio as telemetry module. I followed the installation guide in order to connect the M+ as GPS 2. Used the port S1 and GPS2 port (serial4) in Pixhawk… I used the following setup>

Position Output
DEVICE: UART
BAUD RATE: 57600
FORMAT: NMEA

Pixhawk Parameter>
GPS_AUTO_CONFIG=1
GPS_AUTO_SWITCH=1
GPS_TYPE2=5 (NMEA)
SERIAL4_PROTOCOL=20 (NMEA)
GPS_INJECT_TO=1
SERIAL4_BAUD=57

using the same baud value in Serial3 (gps1), Serial4(gps2), PC-RFD900 and Reach M+ (position output and Correction Input)

But Pixhawk, not get position data.

After reviewing the threads:

https://community.emlid.com/t/setting-up-a-correction-link-arducopter-integration/20235
and

https://community.emlid.com/t/adventures-with-a-reach-m2-intergration-to-pixhawk/20886

I tried using ERB protocol, with the following setup>

Position Output
DEVICE: UART
BAUD RATE: 57600
FORMAT: ERB

Pixhawk Parameter>
GPS_AUTO_CONFIG=1
GPS_AUTO_SWITCH=1
GPS_TYPE2=1 (AUTO)
SERIAL4_PROTOCOL=5 (GPS)
GPS_INJECT_TO=1
SERIAL4_BAUD=57

With this configuration a get GPS data from Reach M+. The question is: **Why I cannot use the NMEA protocol if Emlid mention: **

** “ERB format is deprecated. We recommend using industry-standard NMEA format instead.”**

in your ArduPilot Integration guide.

I could fix the issue with the protocol NMEA changing the Parameter:

SERIAL4_PROTOCOL=20 (NMEA) to 5 (GPS)

It is different that Emild Guide mentioned but works.

Hi Juan,

Thanks for sharing the solution with us! According to our tests, both these options should work. We usually recommend using SERIAL4_PROTOCOL=20 for NMEA and SERIAL4_PROTOCOL=5 for ERB.

However, we will double-check our settings and update the guide accordingly.