Open project doesn't work and export spins

I tried a test survey today for the first time. Two ReachRTK connected via 3DR radios…all seemed to check out.

However, I am now unable to open the project. Open Project does not work, and when I try to export the 10 points into a shapefile, it just spins.

Any ideas? I have restarted and started numerous times. Tried logging in from different computers and phones. All the same.

I had the same issue when using Survey feature for the first time in ReachView 2.5.0. Points were collected successfully in terrain but I was unable to open the same project after restarting Reach device. There were some strange websocket errors in Chrome and Firefox console every time I clicked on project name. Check if you see also websocket errors in your web browser console. If yes, then it can be a bug.
Try with new project and new points. It worked for me. First project can be corrupt I’m afraid.

I’m not sure if this is not new, but Survey bug was fixed in latest update.


Thanks for the report. Seems like this is newly discovered bug. From the look of it, the project somehow got corrupted in a way we weren’t ready for. Can you try exporting to GeoJSON as well? If this fails as well, I may ask to perform some debugging actions.

This shouldn’t really change anything, however if you are using something other than Chrome or Safari on iOS, you should try them.

I did the first survey om a new Reach yesterday (ReachView version: v2.5.3-r0). I’m also unable to open this first survey or export it (also keeps spinning).
Today I did a second survey and can open and export the points but it is stil not possible to do anything with te first survey.

Is there a way to read the coordinates of the first survey?

It’s unusual situation, but you can try to use geodata.geojson file in /surveying folder in Reach root.

1 Like

Thanks for the tip @andrew.yushkevich.
Unfortunally there’s nothing in the geodata.geojson file of the first survey.
Only the metadata.json file of the first survey contains information. I checked this by opening the files with vi.

I guess the geodata.geojson information of the first survey just isn’t saved.

It seems like the file got corrupted. Unfortunately, your data has been lost. Me and @andrew.yushkevich are cooking up a fix for this. Meanwhile, to avoid this behaviour, you might need to properly “close” the project before powering Reach down. To do this, press the little back arrow on the project view.

1 Like

Thanks guys for clearing this up. Next time I’ll close the project before powering Reach down.

Hi @Egor,
I have the same problem right now, with v2.11.0. I can’t download or open any of my recent surveys and that is really frustrating. Moreover, I can’t resolve it, I will lost 3 field work days.
Don’t you have resolved this bug yet?

Hi, I’m using V2.11.0 and am experiencing the same problem. I did a number of surveys on a day and point collection was no problem. For 3 of the 14 surveys (25 points each) that I did, I can’t export the file (none of the formats work). When I click on the survey it gives me a pop up message that reach is disconnected followed by a message that it is connected again.
When I try to export from the survey list it just gives me the message project is being exported. Please wait. The other surveys went flawless (took less than a second). Any idea how I can solve this problem? I need the data for my Phd.

Thanks in advance.

Hi @SanderDR,

Do you still have the same problem with our last version of firmware?

I am currently having this same problem on Reachview v2.14.0 on a Reach M+. I have completed two surveys and the survey export spinning but no export data. I SSH into the M+ and the project metadata is there but nothing in geodata. I had read this thread after the first time and made sure I was out of the project before powering off the M+ but still have the same data loss issues. Please advise.

Hi @kbarto,

Have you tried to update ReachView to the latest version, as I recommended you earlier? Did it help?

Any updates about this ?

I have followed the proper procedure. I closed the project properly before shutting down the emlid, but the file still corrupted. Yesterday I lost 6 GCP points.

Can you confirm your Reachview version?

Version 2.16.2

Hi @AerozoneAsia,

Do you use Reach RTK?

What ? What else?

@AerozoneAsia: I think @tatiana.andreeva is asking you if you use the original Reach modules (a.k.a. Reach RTK GNSS Module) like this:

1 Like