NTRIP parameters not editable in ReachView3


Using a Reach RS2, Fw 2.42.2, last Reachview 3 app on Android, released yesterday.

RS2 is on, in Single mode. When getting into the Settings > Correction Input page of the app, I can’t edit the NTRIP parameters. Clicking on the pen icon does nothing. The other edit icons behaves well. Only the NTRIP icon is like frozen.

Have a look here. The receiver is at the window so the solution status is a bit unstable.
Screenrecorder-2021-02-17-11-57-08-314.zip (4.6 MB)

Any thoughts on resolving this ?

Hi Florian,

Thanks for the report and the screen-cast!

Could you please specify the Android version you’re using and the type of your smartphone?

Hi Polina,

It’s a Xiaomi MI8, Android 10. More info in the screenshot.

Hi Polina,
I’ve got the same problem here on my Moto G7 (Android 10).
First I configured the NTRIP parameters, now the icon does not respond any more.
Restarting RS2 and G7 did not help to solve the problem.

Hi Florian and Simon,

Thanks for the details! We’ll investigate why this happens.

Simon, could you please specify if you have ReachView 3 version 5.5 as well? What firmware version is installed on your Reach RS2?

I think I had similar problem. I think solution was that I changed SIM card. New SIM card had some pre-paid data load on it so it worked. When data ran out, the NTRIP settings greyed out. Re-loading the SIM card with data solved the problem. Since then we have always made sure that the SIM card data load was not depleted.

Hi everyone,

Just wanted to tell you that we’ve discovered the possible root of this issue. Currently, we’re working on the fix.


version 5.5 and firmware v2.24.2
thanks a lot!

1 Like


I am experiencing the same issue with RV3 5.5 and RS2 2.24.0.


Hey everyone,

Good news! We’ve fixed the issue with the editing of the NTRIP profiles. Please update your App to get the solution.

Please let us know if the update works for you!

1 Like

Hi, @polina.buriak! Good Evening!

I tested here and now everything is fine.

ReachView3, version 5.5, firmware 2.24.2. Emlid Reach RS2.

Best Regards,
Pedro Augusto.

1 Like

Hi Pedro Augusto,

Thanks for the check! Good to know everything works correctly now!

1 Like