Not able to round seconds in Rinex file for opus

I have some RS2 rapid static files from the last few days that will not adjust to nearest second via Emlid Studio 1.2. What’s odd is that I could do this with studio 1.1 in the covert to Rinex portion. Even with the new checkbox for OPUS, it’s not rounding properly. I don’t like to set the pre-defined opus logging on the base (im the field in RV3) because then if you want to submit to another service like NRCAN, The interval and satellites observed are not sufficient. When doing any static work, I like to do one second (1hz) with all constellations and decemate with Emlid studio if need be. Can someone test this amount studio. I tried a couple of different rinex files and no matter what setting I try, it will not round to the nearest second. Please confirm if this is a bug in the latest Emlid studio. I posted this in the latest firmware thread but that’s obviously not the best place so I decided to start a new one. I am on the latest beta version and have not quite updated to 29.x.

Hi Zach,

We actually tested it to work, and everything was fine. But let me check it once again. If you share your files, I’ll check it with them.

Totally understandable. And even if we have it working in ReachView 3, it still must work in Emlid Studio.

And thank you for this one! :slightly_smiling_face:

1 Like

Understood. I will send an email to support and reference this thread.

OK. I figured out the issue. It turns out that Emlid Studio needs the UBX versus Rinex 3.03 format for the OPUS rounding function to work. Hopefully, this is something that can be fixed in a future release of studio. I don’t mind logging UBX files as well but it also nearly doubles your storage space on the RS2.

Hi Zach,

Yes, it indeed works for UBX only at the moment. But we hope to make it available for RINEX-to-RINEX conversion as well. It’s at the investigating stage, but I’ll let you know once there are any results.

1 Like

Understood. I am happy with that answer. That would be a nice future enhancement for EM Studio so that folks using opus are not required to log UBX as well. Another option that would work would be if one could log only UBX and not Rinex.

2 posts were split to a new topic: Possibility to recover raw data logs

Hi Zach,

Can we discuss this one a little more? Why would it be useful for you? UBX is accepted in less software than RINEX.

Because of what I mentioned earlier in the thread. I am going to have to go through Emlid studio no matter what. That way, when I convert to Rinex, it rounds to the nearest second properly. If I’m already in Rinex and run this Utility, that function does not work. I’m hoping that this gets fixed in a future release of Emlid studio. If I have to log both Rinex and UBX, it doubles the storage space required.

I got you. If you use no presets in Logging, you can record UBX only. This way it will be recorded with constellations and update rate you set in GNSS settings. While we’re fixing RINEX-to-RINEX conversion in Emlid Studio, this can be a workaround.

1 Like

Thats’s right. I seem to remember that default but couldn’t remember how to get it back that way. Great suggestion. Thanks.

1 Like

You’re welcome!

1 Like