No Wifi, No Connection

Just received two new RS+ devices. Followed all directions precisely. Can see Wifi on both devices however cannot connect to one and the other connects but ReachView hangs indefinitely.
ReachView App - V1.4
Any advice would be appreciated.

Contact Emlid.

also just try accessing the units via their ip address from a browser…i.e. Chrome. that will always work unless something hardware related etc. for some reason I also have trouple using the android reachView app connecting (previous Edison chip non-plus version).

Nope. I get nothing from one and browser will not recognise the other.

Where do I get ReachView 2.8 The instructions tell me I have to have it in order to get to the device IP

Cant find it anywhere for android

Where do you see this?

Latest ReachView “app” is v1.4.

Latest STABLE ReachView firmware is 2.14.

Hi Peter,

What mobile device do you use?

Could you try to connect to ReachView using your laptop or other mobile device?

Hi @panthony,

Please, follow steps from this First update video tutorial.
If you’ll still have the issue after, feel free to write me here.

1 Like

The Reach RS+ Unit when trying to connect to home wifi rapid blinks then goes to solid blue…no slow blink.

attempted same process and both units go to solid blue. they are not connecting to wifi. I have tried both 2.4 and 5.0 and the rs+plus units do not connect to either.


Can you see this LED status?

May I ask you try to connect to another WiFi or mobile/PC hotspot?

Yes that is the status…I will try a mobile hotspot. I’ll get back with you on trial.


Please double check you are entering the correct SSID and Password.

No…neither unit goes to slow bling.

Switched to another hotspot and I got down to the ReachView update…it’s been about 5 minutes…hope not to run out of data…Message - “Failed to perform update”


It seems that it’s the Internet connection issue.
Please, try again with the same/another WiFi or hope not to run out of data could be the reason.

Ok…here is what I had to do.
I have an up-to-date highly encrypted wifi because of the nature of work that I do. The Reach RS+ cannot handle that level of encryption so I had to set up an open wifi in order for the units to speak to each other and communicate on a network for setup. Once I did that everything worked per Emlid instruction. Both units are set up and I have performed a test survey to check accuracy…and everything is dead on the money accurate.

Still having a slight issue with the units not keeping their hotspot settings…but that is a minor issue that can be worked out later.

Fixed point accuracy is right on and float point is very close to perfect.

Thank you everyone for all your help…I’m sure we’ll be talking again.

  • … .- -. -.- -.-- — …-
    .–. . - .

Hi @panthony,

Can you clarify this issue, please?

Overall, glad to hear that you deal with the WiFi.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.