Reach m+ wifi issues

I received a new M+ a few days ago and have been having lots of problems with wifi connections.

First experience was positive : I was quickly able to connect to the M+ hotspot, then switch over to my local wifi AP, and update firmware to 2.14.

After that, it’s been nothing but mysterious behaviour. Note : all these tests have taken place in the same room as the AP router, same location where I did the initial setup . I configure the M+ through the reachview webUI served from its hotspot.

  • sometimes my local wifi doesn’t even appear in the list of available networks; it says “saved (not available)”, showing 0 signal strength.

  • sometimes my local wifi appears, with full signal, but it can’t connect : when I manually try to connect, I lose the hotspot connection (of course), I see my router give the M+ a DHCP lease, but I can never ping that IP ; the M+ soon restarts in hotspot mode.

  • sometimes I can connect to the local wifi, then I try to walk outside (10m away) to get better gps signal, but it’s apparently too far for the M+ wifi transceiver so the connection drops out. Walking back inside doesn’t always succeed in restoring the connection. And if it does, the stream for TCP corrections will not restart. This is disappointing but not unexpected.

  • in hotspot mode, the M+ seems solid. But, I want to use RTCM corrections from a TCP stream, so it’s not really an option, unless I can somehow set up a computer with internet access to pipe the RTCM stream over the hotspot link… not great.

Anybody else having wifi issues ? I thought of trying the 2.15 dev release but I was discouraged by the “cannot downgrade afterwards” warning.

You can downgrade to the latest STABLE version by reflashing the unit. But I think others are having this same problem even on the latest DEV version?

You can search for this problem lately to read up, but I think Emlid is working with them behind the scenes as I am not sure I have seen a solution out front in the forum yet? I would personally like to know if there is a solution also out here in the forums before I purchase any more RS (now plus with Neutis N5 chip) units. I have the Edison chip non-plus versions with no problems.

Have you tried to reboot your Wi-Fi AP? In the past I have got the feeling that my device was blacklisted by the router for one reason or another (either that or some buggy connection settings were stored in the AP/router). For me, a simple reboot fixes the problem a lot of the time.

1 Like

Hi Tim, I hadn’t found any threads talking about this kind of wifi issue, but I’ll look again. Where did you see that emlid were already working on this ?

@bide Thanks, I did try to reboot the AP, for completeness’ sake, but it’s not the problem. Or at least not the whole problem, see the screenshot below. The Reach usually just doesn’t see the network which is literally broadcast from the same room ; 3 other phones/laptops happily report full signal strength .

I also tried different power sources for the Reach : wall USB adapter, battery + stepdown regulator, and straight form the laptop. This last one is “interesting” : I can see the Reach obtains an IP from the router, but I can never ping the Reach, and after a minute the blue LED turns off then starts blinking fast.


1 Like

Hmm, if Reach gets an IP that is strange that you can’t ping it. I suppose maybe Reach is not receiving the message about its IP address.

I doubt it is the problem, but you could try moving your Wi-Fi AP to another channel and see if that changes the behaviour at all.

Hi @chrisb,

Can I ask you to test Reach with another WiFi or mobile hotspot?

We’re working on the new release with network scan improvements. It should come out pretty soon.

At the moment you can try to update to new 2.15.3 dev version with some WiFi fixes.
If in hotspot mode everything is OK, the future release should fix this issue.


1 Like

Thanks Andrew. Will try the dev update; in hotspot mode everything was OK so I’m optimistic.

Just tried the 2.15.3 update :

Still some problems… those two “Known” networks are broadcasting from less than 5m of the Reach. Sometimes it works fine, other times it does that.

1 Like

Hi @chrisb,

Thanks for the report.

We know about this bug.
It’s related to displaying signal strength and will be fixed in next release.

At the moment there should be no problem with connecting to WiFi if you choose one of your networks.


1 Like

Reduce the number of known networks to only one. Switch all other Wifi networks in your house off.
Might be helpful: Connecting new Reach RS+ and M+ to WiFi

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.