No Wifi after Upgrade to 29.2 from 28.1

Hello

I tried to upgrade both my RS+ receivers’ firmware to 29.2. Unfortunately I am no longer able to connect to the phone using wifi. The wifi is appearing but connection fails on both receivers.

I tried to connect using my laptop browser but failed. Am now stuck. I then downloaded the firmware flush tool which I have never used before so that I could follow the instructions and re-flush.

On openning the reachview receiver in firmware mode I could not see anything that resembles what is referred to as firmware image as the docs: (See attached pics below)

https://docs.emlid.com/reachrs2/reference/troubleshooting/firmware-reflashing/


Had the same issue and rolled back to 28.1 but 28 Beta 3 is now available and seems to be working fine.

Hi

I tried to upgrade fro Firmware 28.1
After upgrading for both receivers I am no longer able connect with receivers on wifi. The upgrade was to 29 beta 2

I tried to flush but could not find the firmware image as per
https://docs.emlid.com/reachrs2/reference/troubleshooting/firmware-reflashing/
I also tried to connect via browser as I could view the wifi from my receivers. Further the three lights continue to blink

Hi Petros,

You can’t connect to the RS+ device via its hotspot, right?

The Reach Firmware Flash Tool should offer you to reflash the device to the latest stable firmware version available. Right now, it’s the 28.4 version. You just need to click on the link below the Browse button. I’ve attached the screenshot for reference.

Thanks I have already done that. I had missed that there was need to download the firmware. But now 28.4 wifi is still not as good as my wifi was on firmware 28.1

So far I have only managed to set up the base only coz of wifi connection. Maybe it’s the phone that I am using.

Thanks for the response

It’s this youtube video Hard reset of Emlid Reach RS2 - YouTube that made me realise how stupid I had been, Thumbs up to those two APGLOS guys!

Hi Petros,

Do you mean that the connection of the Reach RS2 hotspot with your phone is unstable?

I am now in a similar boat. I updated the Firmware this morning to what I thought was the stable version!
Yet another onsite failure. I now, can not see any recievers with the APP or the Wifi connection and see now way forward.!!

I finally managed to setup the rover yesterday. After setup however wifi seems to be stable again just like in 28.1. Was using a samsung phone A32 5G as my controller with reachview.

Am relieved that I"m back to normal. But am no longer eager to test the 29 beta 2. Wanted to see how my receivers perform with bluetooth ble

Hi Petros,
I am stuck on 28.4 with no way of entering the receivers on the app or wifi. How did you roll back the firmware.?

Hi James. I am still on 28.4 but luckily after using different phones and different wifi sources I managed to set up each of my receivers on different days

But once set up the wifi seems to be back to normal. I haven’t taken the recievers to the field though but am confident its ok once set up

Hope u succeed setting up.

Oh by the way James I used the browser instead of the a
reachview App
coz the App wouldn’t connect even though the wifi was visible and showed it was connected.

I put the IP address of the receiver on the the app. Imediately after setting up the reachview 3 App communicated with the receiver

Hi Petros,

I see! Can you please specify what other devices you used to set up Reach?

This is really strange behavior, and the 29 Beta 2 update shouldn’t have triggered it. The Full system report might have given us clues, but as your device was reflashed, this info is no longer in the records. However, we’ll think about what might have caused it.

Do I get right that the connection issue was in the ReachView 3 app only, but not in Reach Panel? Reach Panel opens in the Internet browser via IP address.

Hi James,

I see that Julia has replied to your topic. Let’s keep the discussion on each issue separately since common symptoms may indicate different issues.

Yes. The connection issue is the reach App only. Failed to carry out a survey in the field yesterday. Now hoping to upgrade to the 29.2 beta

Hi Petros,

If I get everything right, you often don’t see the receiver in the list of available devices in ReachView 3 when you’re connected to Reach’s hotspot or on the same Wi-Fi network as Reach. But when you access the receiver in Reach Panel, it works smoothly. Please, let me know if I misunderstood something.

If it’s this issue, can you please share the OS version of your mobile phone and the Full system report from Reach? I’ll check with the devs if there are any signs of the issue we can find. Please, send the Full system report to support@emlid.com.

Hi Slepova

I emailed the full report to emlid support

Thanks

Hi Petros,

Received the data you shared, thanks! I’ve just answered you via email. Let’s continue our investigation there - it requires sharing additional data from your receiver, which can be sensitive.

1 Like

Thanks Kseniia

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.