No RINEX file "Processing 0%" Reach M+ v2.18.1

Hi @jbenisz,

Could you please describe how do you usually stop log recording? Do you disable it manually?

How do you power off the unit?

Hi,
Reach is powered from drone battery.
I just unplug the battery.
Until today (version 2.18), M+ never had a problems with saving files after turn off like that.
What do you think?

Hi @jbenisz,

There is an issue with RINEX log processing that occurs when you shut down the unit by unplugging the battery. We’re looking into it now and will provide a fix in one of the future firmware releases.

At the moment, I can suggest 2 ways to stop log recording:

  1. Stop RINEX recording manually in the app before unplugging the power cable
  2. Turn off the unit using the power button in the app

As an alternative, I can recommend recording data in UBX and converting them later.

Hi @tatiana.andreeva,

Thank you for your response.

Do you know when we can expect the release of the new firmware?

So, there isn’t any chance to downgrade the version of the software? Or reflash reach with older software file? I can do it manually with Reach Firmware Flash Tool. I just need a file with f. ex. v2.16 from you. It will help me a lot… I have already 4 units of Reach M+ with 2.18.1…

Hi @jbenisz,

I can’t provide you with specific timelines, I’m afraid. However, I can inform you once we release the fix.

Even if you reflash Reach with a previous firmware version, it’s not possible to skip the update stage. Reach automatically updates to the latest stable version after reflashing.

@tatiana.andreeva

Oh… sad news…

But I appreciate your help.

Please keep me informed about the release.

Thank you Tatiana :slight_smile:

1 Like

Hi @tatiana.andreeva

Any news about new firmware?

Hi @jbenisz,

Fix is on its way, but I am afraid there are no estimates.

Hi @tatiana.andreeva,
Any news?

Hi @jbenisz,

We’re still working on it.

Hi @jbenisz,

A new v2.21.0 dev release is available! :slightly_smiling_face:
It should resolve the issue with RINEX processing.

Please let us know if it works fine. This guide explains how to update the device.

Hi @tatiana.andreeva
I tried and there is no update available. Should I use the “dev updates”?

After checking for updates I still get:
image

Hi @jbenisz,

This is a dev update, so you should hit on the button “Enable dev updates” to get it.

Hi @tatiana.andreeva,

Regarding your last question, I can’t use developer updates for security reasons of our aircraft.

I just checked your last stable version of the software: v2.20.8. Still the same…


I’m already waiting 4 months for your update, and if it comes, it’s still the same problem. I don’t know how you can’t fix for 4 months, something that has worked for several years on your receivers … In my opinion, this is a shame.

Hey there,

We’ve fixed the issue with our dev update more than a month ago. Stable release is taking a bit longer to release.

BTW, with or without developer firmware you should not use Reach as primary GPS device on youre aircraft.

@tobias-dahms
I am not, it’s PPK.

@dmitriy.ershov
I understand … Ever since Tatiana informed me that my problem in the development release is fixed, I have been waiting for a stable version. When it came, I was ready to bet it was the update I was waiting for. I was just pissed off when I realise it’s not. I apologize for my negative tone, but I really was counting on this release. Do you have any deadlines for the next stable version that interests me?

Hi @jbenisz,

I’m afraid we can’t provide you with any estimates on when we release the next stable firmware version.

The v2.20.8 stable release precedes v2.21.1 dev version, that’s why it doesn’t contain fixes from this dev release.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.