No luck with Reach

HI all. I’ve pretty much given up on Reach. When I got them they connected but it only got single fix. I was never able to get a RTK fix. I thought that maybe the new firmware 1.2 might work. I was surprised about the very low activity on this forum about Reach. Either they all work perfectly or nobody cares. Anyway, I went through the reflash procedure - downloaded the 1.2 image. Got the intel phonelite program and installed everything. It recognizes the edison but after successfully downloading about 23%, the program reports a connnection error and restarts to retry. After a number of retries it just aborts the process. It happens on both my Reach modules and on two separate windows pc. I tried the CLI method but it does not recognize the devices at all. The emlid staff has contacted me by email, but I guess there is not much they can do if the Edison refuses to reflash.

So unless someone has some bright ideas about how to get these to work they appear to be destined to the scrap box. Sad. I had a lot of hope for the Reach after a very poor experience with PIksi. Maybe there is a reason why the cm-precision stuff costs $10,000. Maybe I would be better to buy a lottery ticket and buy a real RTK GPS.

1 Like


Sorry to hear that. What version of ReachView have you been using?

The flashing problem will probably be solved if you install windows drivers. Please check the updated flashing docs.

I loaded the drivers from the Intel site as instructed in the flashing doc. In any event they are installed automatically when you install the Phone Flash Lite Tool. I agree that the problem is likely on the PC side as both Reach modules behave the same but I have tried two different PC so there is not much else I can do.

Why does the CLI flashall.bat not work ? I get error when I connect a Reach:
Device has DFU interface but has no DFU functional descriptor
Cannot open DFU device 8087:0a99
… repeats endlessly…

I see no point in updating ReachView if I cannot flash the Reach itself.

Could you please tell me more about your flashing process?

What Windows version are you using?
What is the exact sequence of actions you performed?

We had good feedback with the v1.2 image, this is mainly a flashing issue

I am using a desktop running Windows 7. After turning off the anti-virus software I was able to run the CLI flashall,bat script. I reflashed both Reach modules. They spent a long time with the magenta LED and then they both went blue. I was not able to detect any hotspot. I tried to reflash again but now the DFU device was not found. Reloaded the edison drivers again - message Intel Edison DFU device - device driver installed successfully.
The Phone Flash LIte shows a Merriwether device connected so there must be a valid driver. It asks to unplug and plug in the Edison. The flash starts but the reflashing always terminates early (around 69%) with “wait for device pos on port2/8” message. Then it waits and waits until it times out and fails. The second Reach is similar except it usually dies at 23%. I am not prepared to spend any more time on this issue.I agree it is flashing issue but if I cannot flash the Reach then there is not much else I can do with them. So maybe I can ship these two modules to you for repair or I can just throw them out. I am doing nothing strange - standard Windows 7 machine. Also similar problems on Windows XP laptop.

Hi drwino
Had some similar issues when installing the ‘integrated driver’ from Intel (intel recognizes edison, but flashing Process stops at certain percentages); after installing the standalone driver it worked for me!
( i used the Windows tool using Win10 latest update)

Hi drwino,

I know that what I’m going to say could be too much easy or superficial but… do you have any possibility to reflash the firmware of your Emlid on a Linux machine? It sorted out all my issue with Emlid and I saved a lot of time.

Good luck anyway!


I’m agree with Elisa, the first time I had to reflash my reach I suffered several process aborts/cancel on Windows. I installed some drivers but I couldn’t reflash it on Win. Then I used a Linux computer and tried Linux method… I got it reflashed on 5 minutes. By the way, other member said they could get it on Windows 10 (I tried it on XP). Good Luck!

PD: When my device arrived I only was able to get Single solution, then, when I reflashed it, I started to get Float/Fix. Setting my Ntrip connection properly, obviously.

Thanks to all for the help. I upgraded a laptop from Win7 to Win10. Reinstalled all the intel stuff and now I can reflash the Reach ! So now I have image 1.2 and Reachview 0.1.0. I was able to configure all the network stuff and I can see the sats on the rover ReachView. I see the base sats alongside as grey bars. However, even while receiving 6 green sats it never moved from single. Sky was clear. I will try again tomorrow further away in the field so see if I can get float/fix.

I am happy that helped!

Are you using TCP to transmit corrections? Could you post screenshots of the settings for both Rover and Base?

Tried in open field today. Clear sky. Got 7 to 8 sats green with corresponding gray base sats. Base is set to tcpsvr port 9000. rover is set tcpcli port 9000. All per setup instructions. No luck getting any float or fix. Lots of hours spent to no effect. I think I will now officially give up and put Reach in the Piksi junk box. Time to spent some money and buy a dual-channel L1+L2 industrial grade RTK GPS with CORS correction. No criticism of REACH - great support but it does not work even under ideal conditions so no point in wasting more time. Last post! - Thanks and good luck.

Hi drwino
I believe you are giving up too early; its easy to get a float solution - if the setup is correct; if you provide some more information about your setup on your reach devices - Rover and base - i’m sure somebody can help you; what did you use as a Router? Can u Provide Screenshots of your reach config pages?

This seems to be a problem with the entered settings. Posting screenshots would probably help us solve your problem

A post was split to a new topic: Base corrections over UART stop, only get single solution

If you are interested in selling off the Reach units from your junk box, I might be interested… - Jon

I have also lost many days (weeks) trying to configure my modules (base and rover) without getting a fix, reliable, because althoughby chance I’ve got fix, the coordinates jump and change constantly, so not is what happens. I have been thinking in another alternative, the Piksi (swift navigation). Anyone can tell me if that if works?

Best regards…

Sorry to hear that. You did get float, though? As long as corrections are coming through, you can only slightly tweak the settings, like used GNSS and the dynamic filter. Getting fixed solution depends on so many things, including sky view, distance to base station, even weather. Sometimes, float solution is as good as fix, just take a look with a RTKPLOT.

Hi Egor,

Finally, after many attempts and tweak the settings, I got a fix, but in my WiFi Network, Now, I have to go out, por that bought a pair of 3DR radios. I´ve verified connection between them, and works (with 3DRRadio.exe), but, when I want to set up with ReachView, nothing happens. I´ve followes the instruction lake Emlid docs, but, finally in that documentos not exists solution.

Best regards…