Base corrections over UART stop, only get single solution

I am having the same issues (with single fix). I am connecting the units TX - RX in testing for using serial radio modems. The rover units show satellites from the base, butonly for about 10 seconds before the greyed out base station satellites disappear. The screen shot shows the status during those few seconds


Don’t take any notice of the bad sat fixes - I snapped these inside the house :slight_smile:
My settings:

The grey bars for the base station don’t disappear when I connect using tcpsvr/tcpcli but I still only ever get single as the status. A look at the rover output has the GGA string as non-differential.

Are the units too close together? Or am I setting something up wrong?

The rover will not switch to float until you get good satellite view. It is possible that the reception on base is so bad, that it does not see any sats to send corrections at some point.

Could you please test them outside and if the problem persist we will try to debug further?

Testing has always been outside. I just took the screenshots inside for the purpose of this post. Normally I have a good single fix

So when you get outside you get stable base corrections, but only single solution?

Yes that’s right. But after a bit more reading, it seems that we need at least six solid sat fixes to work. I will have another try tomorrow and take note of the number of locked satellites. I do have other antennas available to improve the signal, but they are active units. I assume the supplied antennas are passive?

And after a bit more testing and a bit more patience the serial connections are working. Sorry for jumping the gun

And after a bit more testing and a bit more patience the serial connections are working. Sorry for jumping the gun

Good that this is solved! If you found the setup difficult let us know what could be improved.

Bruce

The Reach does use powered antennas. The Reach has 3.5 volts going to it’s the antenna. Here’s a link that gives a little more information.

Larry

1 Like

Thanks Larry

The antennas I have on hand are currently getting 10V but I haven’t looked into what they require as a minimum. I might do a bit of shopping around but I am in a hurry to get it sorted before seeding and our isolation sometimes makes it painful waiting for things like that to arrive :frowning:

Bruce

Good to know that there’s more than one farmer on the forum.

You will find that you get better and faster data with better antenna’s.

Larry

Igor

No the setup wasn’t an issue. I was just a bit confused in a couple of places, like why the base wasn’t showing a position or satellites, but now I realise that is normal. I might be having a problem with one unit where it keeps shutting down/locking up so that hasn’t helped either. I will try reflashing it. I have just been outside in the cold and dark to try getting better satellite acquisitions but even with an open sky I could only get 4 (occasionally 5) satellites over 45. It doesn’t help though that I couldn’t get the rover to stay running for more than a few minutes

This will be added with future updates, sorry about the confusion.

If you could let us know more details about what exactly happens we will definitely look into it. On which version did it happen?

It suddenly stops going through it’s normal sequence of led’s pauses for a bit then comes up with solid red light. It is also doing other unusual things like showing satellites ok on the status page but no position, and randomly opening different configurations when I have to reboot it. I’m not going to worry too much unless it still does the same after reflashing.

The rover unit is stable now after a reflash.

I am still unable to get a float/fix because of the antenna gain. This screenshot was taken during one of the very short bursts of having 6 or more satellites over 45 - obviously not long enough to move off a “single” status. I can work on fixing this.

What I do need help with is getting the link between the base and rover through my radio modems. I can get a link using a physical serial connection and using tcpsvr/tcpcli. The radio modems are transferring data but when I looked at what the rover was getting, it was just gibberish as if it was on the wrong baud rate. I went back to the base unit and set to monitoring the serial data coming out of the base unit. This was also unreadable. I tested many combinations of baud rate, stop bits, byte size and parity but couldn’t find anything usable. The radio modems (Elpro 905U-D) require setting the input/output format.
Any Ideas?

Bruce

Well, what you see are binary protocols, so they will be displayed as gibberish in, for example, screen. Seeing the grey bars means the corrections are coming through.

If you updated to the latest 0.3.1 version, you will see baud rate settings with the USB serial device too. If you haven’t, then 115200 should work.

The only requirement is for both base and rover to have the same baud rates. That will be enough if the radios are working by themselves.

Egor

Thank you for your reply. The 4adio modems are RS232 not USB. They r3ceive at one baud rate, transfer at another rate, and covert back at the receiving modem. I have only tested them between compters at 9600/19200/9600. When I set the reach units at 9600 UART, I get data transferring but no grey bars

This is why no data is getting through. You need TTL UART radio, not RS232 or use a UART to RS232 converter.

Ok. Now I understand. I had made an ussumption that the UART referred to a UART chip like a 16550 that would output via rs232. Now that I know it is TTL I can work to find a fix. Thank you

1 Like

Mikhail had a comment in this post that suggested being able to unject power into an antenna requiring > 3.3V


Does a “power injector” prevent power running back to the reach unit? Or can the reach cope with a higher voltage coming back down the line?
Some of the sit7ations that I want to use this in are alongside another GPS unit that has a large high gain antenna running at 10V. Splitting the cable from the antenna to both GPS’s would be absolutely ideal

Bruce