No Corrections Bars on rover in interface

Hi, I have been having trouble with my M2. I have two, one for base and one for rover. I use LoRa antennae to send RTK corrections. Recently, I can’t get the rover to show the grey bars to confirm that it is indeed receiving corrections. I switched to NTRIP service and then I did have the grey bars. As far as I know the LoRa antenna are functioning and have power and the settings are set to 902MHZ and 2.6 Kb/s. Any suggestions?
EDIT: I should add; I am showing a blinking orange light on RX on my LoRa connected to my Rover M2 and I am showing a blinking blue light on TX on my LoRa connected to my Base M2.

Hi @jherbranson,

There can be different reasons that can affect the correction messages transmission. To find a solution, we need more information about the configuration of your devices. Can you please send us the following files so that we could find the cause of the issue:

  • Screenshots of the Base mode and Correction output settings for Reach M2 base

  • Screenshot of the Correction input settings for Reach M2 rover

  • The Simple System reports from both units.

To generate a Simple System report, you should do the following:

  1. In the ReachView 3 app, go to the Settings

  2. Then open General and find the System Report bar

  3. In the pop-down menu, choose to Generate Simple report

Hi, and thank you for your reply. I will try to get the requested information. I did go into the Legacy settings on the base, and I switched on “Antennae serial number” or something similar and that seemed to fix it. There was another check box as well. Should these all be clicked on?

Hi @jherbranson,

You mentioned that your air data rate was set to 2.6 kb/s. Legacy messages are lighter than MSM4; that is why probably the rover started to receive corrections. Try to increase the air data rate on the base and rover to 9.11 kb/s to transmit MSM4 messages.

Please check the following messages are mandatory for transmitting corrections between two Reach M2 units:

  • 1006 ARP Station Coordinates, 0.1 Hz

  • 1074 GPS MSM4, 1 Hz

These messages are optional:

  • 1084 GLONASS MSM4, 1 Hz

  • 1094 Galileo MSM4, 1 Hz

  • 1124 BeiDou MSM4, 1 Hz

Other messages are not necessary for two Reach M2 units.

To be more precise, I need to check the configuration settings of your devices first.

1 Like

Hi, thank you again for checking into this. I am showing the settings how they are now, because I am not able to set the devices back to 2.6 kb/s as they are greyed out. Here are the interface settings:

A picture of my configuration (both are identical):
0

Base

Rover
Screen Shot 2021-07-07 at 1.40.29 PM

…Note that the differential age is old and then the bars will drop out and not return. I should point out that this particular instance is indoors so satellite reception is very poor.

EDIT: Base is set to STATIC, Rover is set to KINEMATIC

Here are the system reports:
Simple Report ROVER.pdf (30.3 KB) Simple Report BASE.pdf (32.9 KB)

1 Like

The other thing I am seeing, is that sometimes the corrections will drop out, then return only with GPS satellites…
Screen Shot 2021-07-07 at 2.46.47 PM
…Then they will drop out again completely. If I wait for more than a minute, sometimes the corrections will suddenly return. The Age of differential seems to go for more than a minute sometimes before dropping out. The rover does seem to hold FIX through this cycle however sometimes it will drop to single.

One last thing, I just noticed my M2 units were running VERY hot, maybe 140f or higher. could this be part of the problem?

1 Like

Hi jherbranson ! What kind of antenna do you use ?
Although I use my M2’s for static only, I’ve got the Harxon GPS 500’s. I also have the LoRa components but I haven’t tried yet. Have you tried checking the antenna cables ? The cables are very delicate and should be used as careful as possible. They’re not like the old Trimble cables as you well know. I’ve got an extra cable for each receiver. My M2’s have never run hot, just warm. I keep them in a small hip pouch bag hanging from the bipods. I’d also check the fittings too as they might be loose from the cables.

Hey Bryan! Good hearing from you! I’m using the Swift antennae per your suggestion from early discussions. I also keep my unit in a pouch, but it its black and the battery right next to it. It got very hot today (too hot to touch actually) and that’s what got me worried. However, I just set everything up in the shade and out of the pouch and they are cool and still having problems. I’ll check the cables.

1 Like

You might want to try using one of those encased freezer ice things. If you can get a small one and put in a Ziploc bag with paper towels around it to keep condensation forming, that would keep the receiver cool. I know it’s been hot out your way, I hope it starts cooling down some for y’all.

1 Like

One of the things that I’m dealing with is that when I average my base, I use a CRTN network and my ‘age of differential’ is never more than a second or two. However, once I switch to LoRa and begin using my Rover, I then have ‘age of differential’ that will got to like 59 seconds of more. At which point I just lose corrections all together or maybe I recover just GPS.

I’ve been reading and you should try Andrie’s suggestion. It could be as simple as too much data going to the rover. I’m going to try and set up my LoRa this weekend, been up/down with back issues last 4 months. Sitting on my butt in the office in AutoCAD world doesn’t help much !

I did some testing and found that when I set the base to send corrections for only two constellations, then the problem stops. I tried sending corrections for only GPS+GLONASS and then I tried only GALILEO+BEiDOU. This is being done at 9.11 kb/s. I should note, this problem does not occur when I am using NTRIP.

1 Like

Does indeed sounds like you are sending too much data for the 9.11 kb/s. You should increase the bandwidth setting or lower the amount of messages being sent pr second, or lower the number of constellations being sent.

3 Likes

Juel,

It looks like, indeed, there is too much data for the rate of 9.11 kb/s.

Let’s try the following settings:

  • Air data rate set to 9.11 kb/s

  • 1006 message 0.1 Hz

  • 1074, 1084, 1094, 1124 MSM4 messages 0.5 Hz

  • turn off 1008 message

Could you please do a test with your units with the settings above?

  1. Place the base and the rover for few meters apart

  2. Log data on both units for 15 minutes. We need raw, position, and correction log from the rover and raw log from the base

2 Likes

Hi. Here are the results from my test. Settings are exactly as you describe above. The test is about 15 minutes (last stretch of the log). Receivers are about 4 meters apart (see below). I still have corrections drop out according to the interface. Please let me know if you can use any further information from me. Thank you!

3 Likes

Nice equipment Jherbranson !!

3 Likes

Thank you, Sir! They are the result of your advice and recommendation!

1 Like

Juel,

Thanks for the data!

I’ve checked your files, and it looks like the issue may be with cable or LoRa antenna connection, as @EBE111057 suggested.

To ensure this, I suggest swapping LoRa antennas from Base and Rover between each other and repeating the test. This is because the LoRa antenna is configured only to send or receive the data and uses different pins for that.

2 Likes

Good news. Ok, can I possibly reorder a couple sets of cables? They have taken a beating out in the field. I will also try a swap. Thanks!

Ok, I ran another test. I switched the cables around between the two sets of units (keeping the M2 and LoRa paired as before) and I was still receiving errors, so I then swapped the LoRa units around to different M2 units and allowed the logs to record data (I am still seeing corrections drop out intermittently). I have included these new log files below. Thank you again.