New reach update question

I reflashed to the new beta firmware. Can’t seem to get hooked to my router hotspot after that. I have got the router named and password and saved. From there I rebooted and the router shows and I click on connect. That’s it says lost connection to reach but never connects to my router? Reach module does not show up in fing under the router either? Any ideas

What lights do you see on the reach? If green, it means it created its own hot spot and didn’t connect to your WiFi. If that’s the case, make sure you have the correct WiFi settings in the new ReachView 2 landing page. Then reboot Reach. If it still didn’t connect to WiFi, then you may need to re flash. I had to reflash one of my reaches but not the other.


Thanks for trying it out. Are you sure Reach does not create a hotspot again? Unless something goes very wrong, it is designed to fallback to previous state, when connecting to a network.

Thanks for the replies. When I click on connect the module disappears from the wifi list and then after about 30 seconds the app says lost connection.I reboot the reach and nothing, after about 2 minutes the reach hot spot shows in the wifi list again. I can the repeat the last few steps again. The light is solid green when its own hotspot is on. Guess I will try reflashing modules again, both units do the same thing.
I just checked under the I on wifi and there is nothing showing for any of the dhcp settings ie. no IP Address etc., I think there should be something showing ?


I reflashed the firmware. Still getting the same results

Are you on the beta? Please post screenshots of your WiFi settings.

That’s weird!

You should actually not reboot the device, just find it in the new network, you connected it to.

Please describe the steps you did exactly. After reflashing the device, you connected to its hotspot, right?
How did the updater screen look like? Maybe post a screenshot? What are the network credentials you added? Are you 100% sure that they are correct? After connecting, did you reconnect to the same network you added Reach to? Do not reboot Reach after connecting, wait and see if the hotspot reappears.

If that’s possible, you can try to ssh into reach and post output of the following commands here:
cat /etc/wpa_supplicant/wpa_supplicant.conf

Try setting your reach up again but with cache turned off or in chrome at incongnito mode.

I am on laptop with windows 10 and firefox browser, tried windows browser same results.
attached screen shots of what happens:

I had the same window as you. I finally may it with chrome in incongnito mode.

I tried to reflash but without success

what’s wrong ?



I see you use chrome i normal mode, have you tried incongnito mode?

Sorry what do you mean ?
I connect my reach via usb to the laptop then I launch the intel_edison_setup_win_v2016.2.007.exe but nothing seems to happens …



another question
when I plug viausb my device to the laptop (win7) the device isn’t recognise maybe the driver isn’t correct installed ? How can understand if the reach is corrctly plugged to the laptop ?



Sorry, my bad.
You installed this driver first ?
And reach light up whenyou connect it to usb?


I got the same problems / screenshots as jmcarthur and Francesco_sisani.
What worked for me was access using (after following the setup Using Ethernet over USB and always waiting for the green LED before going on and some reboots and patience and an IP- scanner and … finally it worked on one Laptop (had no success on another Laptop, both Windows 10).

Well, i hit the same problem with my second unit. All went well until reach should connect to my wifi, but nothing happend.
So had to reflash and this time it worked.

And regarding this images (i have the same), when you press “flash firmware” it scans for some time and if a image comes up with a connection diagram and you can not hit “next” , i disconnect reach usb and reconnet it. That worked for me.

Good Morning
My flash program looks a little different than yours. Mine actually tells you to unplug the usb and replug and then does the firmware flash. That part is ok for me. My screen shots above are after the firmware flash is done, when the reach app comes up it connects to the reach module on as it should. It is wanting to do an update so asks for a wifi connection with internet access to be entered, I am able to do that and save it. I am then able toclick on that wifi spot, “netgers48”, the app then appears to be trying to connect to it. After about a minute of trying the reachview app says it has lost connection with reach. When I check the list of hotspots then the reach one is gone as it should be, but the reach does not show up in my internet connected hotspot, “netgear48”, list all other devices do. The reach module does reappear after several minutes which is what Egor has said it should do from above.

I have entered my hotspot “netgear” with different security features etc. Tried rebooting, not rebooting,waiting for several minutes does not make a difference.

I am using a dell laptop with windows10 and have tried windows browser, firefox browser both of them in normal and private (incognito) windows. I have also tried from my phone with safari browser.
I have flashed firmware on both reach modules and reflashed one of the modules again.
All of these give me the same result?

Sorry this is so long but trying to give as much detail as possible.

Thanks in advance for any help.


See my bold text above. I have a different approach