New Reach RS+ will not update

Reach rs+ was started according to start guide and video tutorial but would not update.

  1. firmware version unavailable, ReachView version 1.5 as downloaded from App Store.
  2. system report unavailable
  3. description: following instructions from “User Guide RTK GNSS Receiver Model: Reach RS+ Version 2.2 May 2019”, I made available a WiFi network with internet access, and a smartphone with ReachView app version 1.5 downloaded from App Store for an iPhone 7. Per instructions of the guide, I watched video version of this tutorial.

Turned Reach RS+ on.
Opened WiFi networks.
Joined “reach:8C:E7” using password “emlidreach”
Opened ReachView app.
Tapped “reach
On Welcome to ReachView page, tapped plus and added my WiFi network and password and saved.
Tapped on my added network, On the pop up box with my network name and the words “Security: wpa-psk”, I selected connect.
This returned me to ReachView Welcome page. At the top was a Red box with “ Reach is connecting to another network. Switch to (my WiFi network) to continue”.
In settings I selected my WiFi network and joined that. At this time the blue indicator on the Reach unit began to flash for several seconds, then went steady.
Returning to ReachView app, the Red box with command to switch to my network remained. I waited for approximately 40 minutes without a change in status. During this wait time all three indicator lights remained steadily lit. No further prompts were displayed, nor were any selections active on this page.
Of note was the fact that the network “reach:8C:E7” remained available in “My Networks” during this period.

Numerous attempts were made using the same instructions after a shut down of the unit, removing and reentering home WiFi network and password information, and deleting and re-downloading ReachView app. All with the same result.

Any help in this matter would be greatly appreciated. If I have not included all necessary information please advise.
Thanks in advance.

Hi @robuell,

May I ask you to add the screenshot of the Updater page that you’re always faced with?

Would you mind elaborating whether you tried to connect your Reach RS+ to different Wi-Fi networks, for example, your smartphone’s hotspot?

Hello Polina,

This is the screen that the update stops on.

I have tried another WiFi network with same results.

I did not try phone hotspot as I was unsure how to manage network changes required to follow Reach from network provider to my phones WiFi network at the update transition.

Also a photo of my WiFi settings page at this time.

Hi @robuell,

Thank you for the photos!

Do I get it right that your access point is using the 2.4 and 5 GHz frequency at the same time? Reach units do not support the 5 GHz Wi-Fi networks, that is why the unit might not connect to your Wi-Fi network which automatically directs it onto the 5 GHz channel.

Could you please share the Wi-Fi from your iPhone to check if that could be indeed the issue? Please, follow these steps to do that:

  1. Make sure that the Wi-Fi is enabled in the iOS settings. At the same time, your iOS device should not be connected to any Wi-Fi network

  2. Navigate to the Personal Hotspot tab. Make sure that you have allowed other devices to join

  3. Specify the network name and the password in the ReachView

  4. Keep the Personal Hotspot tab opened until RS2 is connected

You can still access the ReachView interface from the phone sharing the Wi-Fi as both devices are technically connected to one network.

Connection to the only-2.4 GHz network would enable us to tell whether such behavior is reasoned by the Wi-Fi network. If you will be able to connect to the hotspot, could you please share the updater page screenshot after that?

Thank you for the response. Please standby for a few minutes while I try that.


It also seems to me that there is a TC871785 network with no 5 GHz prefix in it. Do I get it right that this is the same network on the 2.4 GHz bandwidth? If yes, you can also try connecting to it.

Using the iPhone hotspot does not seem to work.
The reach does not show up in available networks though, and the blue light is slowly flashing. Perhaps it is searching for network?

I will try the non-5g network.

If the blue LED is slowly flashing, you can go directly to ReachView app on your iPhone, you’ll see Reach in the list of devices.

The network that had the same name, except the 5G, is apparently my service also. I was able to connect with the same password. I had to delete ReachView and download again to get rid of locked screen. I was then able to connect to reach network, enter non-5G network name and password, then connect. The same screen lock occurs after this attempt. Reach network does not show available in networks now, unlike previous attempts.

Also, blue light continues to flash slowly.


Could you please share the screenshot of the ReachView app at this moment? Is it the same updater page?

Also, could you please install the network scanning app like Fing and check the devices in your network? The RS+ should appear as “AMPAK Technology” over there.

Yes, same ReachView screen. See photo above.

Standby while I download recommended app.

Hi @robuell,

If I understand correctly, you tried to connect the Reach device to a non-5G network which is TC8717T85.

You mentioned that the blue light is now flashing slowly: that means that Reach has been connected successfully.

Could you confirm it’s so?

Hi @robuell,

I got your PM. You now should be able to comment in this thread again.

I’ve also noticed that on the screenshot with the Fing app your device is connected to a 5Hz network. Please, try to do the following:

  1. Connect your device with ReachView app to a non-5Hz TC8717T85 network
  2. Open the ReachView app on it

Please post a screenshot once you do it.

Hi @robuell,

Have you had a chance to connect your device to the TC8717T85 network? Did it make any difference?

I would have responded sooner, but I had to wait until it was tomorrow in Emlid zone as I had reached my daily new user limit on replies. I must say, with all due respect, this being the only means of tech support, it makes little sense to place limits on accessibility. Especially for new users, who may have the greater need for it.

By some combination of reboots, using non-5G network, and reinstalling ReachView, it did get through the update process. I am not certain what made the difference, so unfortunately I cannot contribute much to the knowledge base.

Presumably it is the latest update, and will not need it again soon. The reach works fine when it is started out of range of a known network. It makes itself a hotspot, displays steady blue and may be selected in WiFi networks. ReachView seems to have full functionality.

When a known network is available at startup, it will become a slow flashing blue.
With my iPhone:
When I select my non-5G home network and try to open ReachView it displays the message “no connection” and accepts no further input.
With my iPad:
Connected to the same non-5G home network, ReachView connects and is fully functional.

Edit: Restarting the iPhone clears the “No connection” message and restores functionality of ReachView.

Thank you all for your assistance.

1 Like

I have found that the issue involves using ReachView from the desktop icon.

When starting up Reach in range of the known home network it will connect itself to that, indicated by slow flashing blue. With either iPad or iPhone, launching ReachView from desktop icon works fine. If Reach hotspot is selected on ReachView, Reach transitions to that mode as indicated by steady blue. Reach view displays a message to select reach from available WiFi networks. After selecting reach from available networks and returning to ReachView, the message remains locked and no further selections are possible.

The workaround is to open browser and use
This brings up a functioning ReachView. The desktop ReachView remains locked on message. Another workaround is to shut down and restart mobile device. Then ReachView desktop icon opens normally.

This same issue occurs when switching from Reach hotspot to home network. After selecting home network from ReachView, Reach connects, indicated by slow flashing blue. The message “no connection” is displayed on ReachView. From device settings the home network is selected. Returning to ReachView finds it still locked on “no connection” message.

Here the workaround is the same. Using Fing, the Reach address, in my case, can be entered into a browser to get a functional ReachView. The desktop ReachView remains locked. As before, if the mobile device is restarted, desktop ReachView becomes functional.

Either workaround seems fine to me, I just wonder if it is normal, or of concern to other users.