New Reach RS + No green light

I have a week old Reach RS +.Updated software. Worked for 8 hrs. Now I get. Red and Blue with no Green. I can WiFi connect, Network connect and SSH connect. Tried several button resets and software reboots. No luck getting it to work. Test and update checker works with no errors. It seems like the APP want start. I have free disk space…I only collected data for a few hours. Any suggestions… do I need to flash it?

Hi Stacey,

What happens when you try to connect to the receiver using ReachView app or web browser?

When I turn it on I have a Solid Red and Blue light with NO Green light. I Wi-Fi connect Direct to the Reach RS+ and use the ReachView app I get the “We can’t seem to find any Rach Receivers in your local network”. #3 ReachView version must be at least v2.8.0. If I then hit in a web page all Test are OK and I can Add new Wi-Fi network. Next I add a Wi-Fi Network (I have added three Wi-Fi networks to ensure thats not the issue).

I have it connect to a Wi-Fi Network… Solid Red and Flashing Blue light No Green.

Next,From my iPad that is also connected to the same Wi-Fi Network. I scan the Wi-Fi Network the Reach RS + is connect to and find the Reach is on With Services of SSH on Port 22, Callbook on Port 2000 and UPNP on Port 5000.

I try ReachView again and get the same “We can’t seem to find any Rach Receivers in your local network”. #3 ReachView version must be at least v2.8.0.

I now go to a webpage and hit Green Check on Test, Wifi, Time scync, Reciever update, and ReachView update. It says the current Reach Version is 2.11.2. I select “Reboot and go to the app!”

Reach RS+ reboots. Solid Red and Flashing Blue light No Green. I can SSH into the receiver.

ReachView will never connect.


and try and connect


Thanks for thorough description.

Could you try to open in a web browser when Reach RS+ is connected to Wi-Fi network?

If I run the flash tool and connect the unit I get this error. I have not tried to flash it, just see if I could connect to it. image

If I try and connect directly to http:\ or I get cannot open the page because it could not connect to the server.

I can hit and with Filezilla using root\emlidreach login.


What OS is that?
May I ask you to try different PC and reflash the unit?

Windows 10. I can try a different PC. Could you confirm the software version I need to use to flash the unit? I have reach-plus-v1.10.sdimg.

I can confirm it’s the latest image.

It worked!! Here are my notes:

  1. Be sure to use the cable that came with the Reach RS+. If you contect Reach RS+ before you go into Firmware Update mode, PC will find the Emlid Nec??? driver on the USB. This is a problem when trying to flash later on.
  2. Ran Zadig and installed the WinUSB to Unknown Device renamed to EMLID.
    Flash Tool: It starts by Initializing the emmc. Once it reaches 100% it will disconnect the USB EMLID and reconnects to a storage drive. Here it tried to use the EMLID Nec??? driver.
  3. I had to go into Device Manager and remove device EMLID NEC??? AND delete the drive (it is a check box).
  4. Went back to the Flash Tool. This time it found the Storage Drive. F:
  5. Browsed the Image and hit Start. Came back on with all lights on.
  6. Direct Wifi connected… did not need to update. Had to reset to a local network. Found on local network with my Android. ReachView worked… started tracking.

So what caused the problem to begin with?

  1. I might have ran out of memory. Collecting raw data. (I erased the survey log files using SSH)
  2. Student turned it off, but might have done a reset by holding the button too long.
  3. Dodgy system?

4 posts were split to a new topic: Reach RS+ doesn’t turn on and doesn’t charge