Need help with GStreamer on the RPi 2 Image for Navio2

I’m very inexperience with Linux, and was hoping someone could help me out setting up GStreamer on my RPi2. I’ve downloaded the latest image for Navio 2 and followed the instructions in the docs:

sudo apt-get update
sudo apt-get install gstreamer1.0-plugins-good gstreamer1.0-plugins-bad gstreamer1.0-libav

When I try to start the camera I get:

-bash: gst-launch-1.0: command not found

It fails to download some files during the install. Any tips on how I fix this?
(I’ve tried other methods of installing it, but all with the same result)




Please, try to install gstreamer1.0-tools.

1 Like

ok, thanks for fast reply! I did:

sudo apt-get install gstreamer1.0-tools

The install seemed to go fine, no error messages, and it was able to download everything.

When I now run the camera i get a different error message:

WARNING: erroneous pipeline: no element "h264parse"

So I guess something else is needed too…

I’m not running an Navio2 but that missing h264parse was something i had difficulty with on Navio+. It doesn’t look exactly like your issue as mine was not installing but maybe something here applies for you as well. See this thread–> [SOLVED] Video streaming with gstreamer


That’d be very strange, if the exact same solution worked, because the testing repository at the time had corresponded very closely to the current jessie release. I also had known that testing was going to be named stable very soon, that’s why I could’ve more or less safely recommend people to dist-upgrade. That’s not the case now, because the gap between jessie and stretch (that’s the codename for next Debian release) is way more drastic. So the dist-upgrade is not safe at all.


I’m going to look into your problem anytime soon. Sorry, for missing packages, anyhow.


I had similar problems, I followed the instructions provided and had a similar h264 error. But today I reinstalled (without removing) all on the gstreamer plug-ins (good, bad, ugly) & libav, and many additional elements where installed. Streaming is now working perfectly with the provided command line.



Tried a few more times with a clean new image (RT for NAVIO 2), same result.
Tried with the normal (not RT) image and with this the camera works.
So I guess there are some files or settings missing.
Thanks for looking into it!

@george.staroselskiy how should I start the raspivid and gstreamer on boot? Putting the command in /etc/rc.local starts the raspivid bud gstreamer does not transmit. The same command deos work then executed manualy after boot. Any ideas?

Hello guys. Im just using
apt-get install gstreamer1.0

Works perfect… :slight_smile:

I reinstalled everything one more time using your suggestion Bernt, I tried your simpler install earlier without success,but this time it worked! (perhaps some of the servers were down the first time I tried, not sure)

Starting with the RT image from the Navio2 docs:

sudo apt-get update
sudo apt-get install gstreamer1.0  (TAKES A LONG TIME)

After this I streamed with this:

raspivid -n -t 0 -rot 180 -w 640 -h 480 -fps 30 -b 1000000 -o - | gst-launch-1.0 -e -vvvv fdsrc ! h264parse ! rtph264pay pt=96 config-interval=5 ! udpsink host=[IP OF PC] port=5000

Latency with WiFi connection around 200ms:

1 Like

Ole does the stream go down through the data link radio?

No, through the WiFI connection. When I fly I use a 4G connection. (Not Mavlink, that is just for APM, video is separated)

have you tried video over the 4g connection with those settings? I can do it perfectly over wifi but not over 4g, its extremely laggy. When i ping navio on 4g the time is between 150ms and 500ms

@ddomit it’s probably because of the poor 4G reception, judging by your lag values.
Try to locate 4G modem in a better place, check signal level etc.

The weird thing is that im getting speeds of more than 20Mbps on that 4G :confounded:

@ddomit try another modem or network operator, maybe that will help.

A post was split to a new topic: No output from Navio2