No output from Navio2

hello guys , i have situation pretty hard .
I have a drone running raspberry pi 4 and navio2 , i wanna use a camera i have install gstreamer i can stream from the pi but i dont get any output ? i have used the app qgroundcontrol in my phone and windows but no output out …what im doing wrong? i will really appreciated your help.
Thank you

Hi @cybersecdo,

Welcome to our forum!

I assume you already did but still, can you specify whether you tried following the instructions from our guide?

Do you receive any error messages in QGroundControl about the absence of the video input?

Hi there, so yes I have followed all the instructions.
If I’m using Ubuntu I can receive video but if I use the android app QGroundControler no video coming up…

Hi @cybersecdo,

It seems like the issue is the app platform-specific. I remember recently, one of the users shared that they had difficulties with arming using QGroundControl Android app. However, when they tried the app on Ubuntu, it worked fine. I suppose it could be somehow related.