Navio2 + RPI4

Hello, Im new to Navio2. Recently, Ive tried to setup Navio2 to work with RPi4 and a 64Gb SSD.

I followed the Official Emlid instruction and downloaded the latest image to flash onto the SD (http://files.emlid.com/images/emlid-raspbian-20190227.img.xz), modify wifi connection info inside wpa_supplicant.conf, and finally power it on.

To no avail, I was not able to ssh into the pi despite scanning all available ip address and even using pi@navio.local but nothing worked.

I noticed upon powered on, the LED on Navio2 is always green, but the LEDs on Pi4 were both green and red for a short while then the green went off with only red LED left (standby?). I’m 90% sure that it doesnt boot up properly with this image since Ive used the pi4 with other non-Navio builds before and it worked just fine (green LED was always on).

Any idea on how to proceed or further debug to see where the problem might be is greatly appreciated. Thanks.

Hi @ray,

At the moment, Navio2 doesn’t work with Raspberry Pi 4. However, we have plans on adding RPi 4 support.

​Currently, you may use one of the following RPi boards with Navio2:

  • Raspberry Pi 3 Model A+

  • Raspberry Pi 3 Model B

  • Raspberry Pi 3 Model B+

  • Raspberry Pi 2 Model B

Thanks Polina, I guess I have to go back to the 3B+ now. Pls let me know when Rpi4 updates become available later. Thanks :slight_smile:

Hi Ray,

We’ve released a new Raspbian image with Raspberry Pi 4 support and other new features and improvements.

1 Like