Navio2 Rpi4 Randomly Freezing in flight

Hi all
im using Rpi4 and Navio2 and all calibraitons and settings check and okey but freezing navio2 and led solid flash. İm using latest navio image

Connect your Navio2 to a groundcontrol software such as Qgroundcontrol and see if there are any messages.

Are you only powering via the servo rail?

ssh or directly on the Navio PI type “dmesg” in terminal and post that here.

Also which Emlid image are you using?

Hi @Akay_Yesiloz,

Could you describe how do you power the motors?

Also, if possible, please, share the photos of your hardware setup.

Yes using standart emlid image and freezing only navio and ardupilot and rpi not have a problem

All power shematics same i try servo rail,usb cable and power module all its same result freezing armed or disarmed situation

I was using standart s500 frame and using this frame pdb with Sunnysky eolo 50A pro esc, sunnysky 2212 motors and 4s 10ah lipo

Hi @Akay_Yesiloz,

Could you connect to Navio2 via SSH after freezing?

Yeah rpi doesn’t any problem im connecting ssh

And we have 9 navio2 all cards have same problem !!!

I want an urgent solution so I dropped 5 drones and my customers also dropped 4 drones due to freezing

Other 5 drone shematics

  1. Drone 6 motor sunnysky v5210 and eolo 50a pro esc not have pdb rpi4 4 gb ram 32 gb class10 sd card
  2. Drone 4 motor tmotor u8 and tmotor flame 60 a esc have a pdb rpi3 16 gb class 4 sd card
  3. Drone 4 motor hobbywing x8 agriculture arm set have a pdb rpi3 32 gb class 10 sd card
  4. Drone 6 motor hobbywing x6 agricultura arm set have a pdb but power module lipo external 3 s 5000 mah rpi2 class 10 64 gb sd card
  5. Drone 8 motor sunnysky x4110s and tmotor flame 60a esc have a pdb rpi4 2 gb ram16 gb class 10 sd card

all configrations are different from each other and REVD Navio2 is the only device which has common features.

Hi Akay,

Could you clarify which flight mode you use?

Some flight modes require GPS lock prior to take off. For example, the Auto flight mode. Navio2 indicates a GPS lock as a green LED light.

Are u kidding me ?


I noticed only the blue LED in the video you attached. It’s important to know your flight settings because LED status might be critical in some cases.

To figure out what might cause the issue, we need to exclude all possible reasons associated with the ArduPilot workflow. So, if you are sure that all preflight conditions are met, please, send me the dataflash logs. It would be of great help in troubleshooting.

I’ll try to check it and answer you as soon as possible.

use the se image and use a pi 3 and see if that helps. You will get very frustrated waiting for Emlid. Also have you tried uprading to copter 4.0 You have to connect your Navio to either Qgroundcontrol or Missionplanner so that we can see if there are any messages.

So answer Tatiana’s question. In which flight mode did you do the test there. Where you in Poshold or perhaps Stabalized. The thing that we need to eliminate here is that you are not flying and it might be that the FC is detecting this and disarming. So please follow advise and replicate the exact same conditions as we are seeing in the video but include the messages from Mission planner or Qgroundcontrol.

Also stop using class 4 sd cards and use class 10

the autopilot closes without knowing if it is flying anyway, as my drones have fallen in the previous 3 flights, I will not test by flying again

gcs says the connection is lost without any warning

There is nothing that notices in flight mode or SD card. All flight modes have the same problem and the problem continues in class10 cards.

Yes this sounds remarkably like previous crashed I have had where the drone would start toilet bowling and then I would get the connection error on Qgroundcontrol

Hi Akay,

Is there any chance you can share with us a log recorded during these tests? These files should help us a lot in determining what’s the reason.

Also, it’d be great if you post the output of the commands I sent you earlier.

2 posts were split to a new topic: Sudden fall of the drone

I have had also sudden falls experienced recently.
However, after upgrading to Arducopter 4.0.3 it hasn’t done anything unexpected anymore. The only drawback is due to a bug the status LED doesn’t work on this version. You have to rely on ground-station in regards to status.

I discovered the version update problem, but when I changed the sd card I used, all the problems were fixed. I found out because this is because the sd card reading inputs cannot transfer fast enough, pay attention to quick response especially when installing version update on poor quality sd cards. if the transitions are not fast while coding, rasperry freezes and does not process.

emlid is really very interested. I’m very satisfied. There are also some minor problems with other cards.I think navio 2 is much better than pixhawk.

Well lets see. We have been asking this now for a while together with things like support for dshot and blheli and there are never any answeres as to exactly what Emlid has planned for future releases.

Why do you say that. What makes the Navio2 better than pixhawk. Navio2 is great yes but for example does not have support for either blheli or dshot protocals