Navio2 - HIL mode with x-Plane 10

Can I simulate the plane using HIL with Navio2?
If yes, how can i do that.
If no, please support that. :smiley:, i think we should have that feature.

I going to use the ArduPlane firmware on Navio2.

Thanks.

It should work same way as here.

I stuck in:

Load the HIL Simulations version of the APM software with the Mission Planner (circled in red below; pick the one for the aircraft you want to simulate).

My setup steps:

  • Connect Navio2 & PC via UART
  • run on navio2: sudo ArduPlane -A /dev/ttyAMA0
  • Try to connect in Mission Planner, Mavlink worked.
  • Disconect to load HIL firmware
    –> Mission Planner can’t dectect board.

So, how to load/run the HIL firmware ?

So, how to load/run the HIL firmware ? I follow your link and it NOT worked
How did you team simulate / verify the firmware on Navio2 ? We must have a method to do that.
I just want to ensure the software on Navio2 work fine, and test some modification in the future.

Thanks

HIL does not work since inertial navigation was introduced with Copter 2.9. The closest alternative we have is SITL.
http://copter.ardupilot.com/wiki/hil-quad/
http://dev.ardupilot.com/wiki/setting-up-sitl-on-windows/

Is HIL now supported by the Navio2?