Navio2 - Growing wobbles until it crashes

I took it out for its maiden flight today and something is horribly wrong. Did I miss something?

While its on the ground, it throttles up and down and looks really normal, but as soon as it gets off into the air, even slightly, it starts wobbling, each time getting more and more dramatic until it crashes.

It takes it about 3 seconds from being airborn to crashing.

Any ideas?

Any logs?

How do I get to the logs?

You can use the Mission Planner.
Detailed instructions

You flew in Stabilize mode ? or Poshold ?

first thing to do is analise the logs.

@Nathan_Belk, Do you have any movie ?
I have PWM sync error that ESC Update Speed (ArduCopter:RC_SPEED) was happened to be set to 490Hz. This speed set is too fast for my Q Brain 4 x 25A.

Wobbling can be caused by bad PID settings and because of vibrations.

Qbrain = Crash

APM 2.6, Pixhawk, etc…etc…etc… and Navio.

I have a lot of vĂ­deos, to prove.

The problem with Qbrain is the “frequency” in fast commends or similar conditions……… with old APM hw works not too bad.

I spent one month to understand the problem….really hard….…. After more than 20 crashes, I simulate the problem on the ground …. With one axis platform, believe I know what I’m talking….

And the problem occurs without “loops” too…. With fast commands…. Really sorry, real problems….

The crash “will happen” with fast commands or in special conditions…… roll or pitch….depending on the pids tuning….with very good tuning the problem will occurs sometimes, but again I really respect your choices….

Video with Q Brain (look the video description) 1 year ago….

Video after change Q Brain

I’m not using the Qbrain for this build.

This is the analysis I got. I will post the actual logs when I get to work.

Log File E:/WindowsTmp/tmpD6AA.tmp.log
Size (kb) 5586.0341796875
No of lines 72269
Duration 0:08:09
Vehicletype ArduCopter
Firmware Version V3.4-dev
Firmware Hash cce4f12e
Hardware Type
Free Mem 0
Skipped Lines 0

Test: Autotune = NA -
Test: Balance/Twist = NA -
Test: Brownout = GOOD -
Test: Compass = FAIL - WARN: Large compass offset params (X:-101.00, Y:-451.00, Z:-15.00)
WARN: Large compass offset in MAG data (X:-101.00, Y:-451.00, Z:-15.00)
Large change in mag_field (230.74%)
Max mag field length (702.06) > recommended (550.00)

Test: Dupe Log Data = GOOD -
Test: Empty = GOOD -
Test: Event/Failsafe = FAIL - ERR found: CRASH
Test: GPS = FAIL - Min satellites: 0, Max HDop: 99.99
Test: IMU Mismatch = NA -
Test: Parameters = GOOD -
Test: PM = NA -
Test: Pitch/Roll = NA -
Test: Thrust = NA -
Test: VCC = GOOD -

How do I know if its vibrations or if its bad PID settings?

I’ve balanced the blades and I support the navio/Pi using the foam antivibration pads from HobbyKing.

The full log file is too large to post, what parts do I need to grab from it?

Also, I already set the RC_Speed to 50 to get everything to work properly with a gimbal.

I forgot to mention that this was all in Stabalize mode.

ops sorry…my fault

vibrations you can analyze using mission planner

PIDs, are easier , if you have bad PIDs, when you “push” fast commands like roll or pitch, the multi will “swing” a little before full stabilize, with correct pids , is fast the stabilization.

Other importante thing is magnectic fields, you can analyze with mission planner, using Compass Motor

thanks, I’ll look at those durning lunch today. Does misson planner store a log of vibrations or do I have to have everything connected and live when I try it?

Also, there is a ferrite bead on the 5v line of my BEC. It is ended up right next to the navio while putting the lid on. I didn’t think anything of it at the time, but the magnetism part concerned me? Are ferrite rings magnetic or would they interfere?

It looks something like this:

I have also these ferrites in my BECs, without problems, but I really don’t know.

Regarding logs, you have too types:

  1. Dataflash Logs.
    APM stores these logs in your board, so you have to download to analyze, (.log files).

  2. Telemetry Logs
    Mission planner store in your computer when you are using Telemetry. (.tlog files)

Today, there is a lot of pre-formatted (templates) filters to analyse the logs, you have to select “vibrations” for example, and mission planner will show the graphs……

Other very good features in mission planner is the EKF monitor and Vibe monitor in your main screen (online-realtime), only click in EKF or Vibe and you can see any issue.

Here is my vibration graph. I don’t know what I’m looking for. What other graphs should I look at?

i’m not a specialist …

but you are looking for Errors - Like - CRASH_CHECH-1 in red… but you have to analyze if happens after or before the crash… thats the point…

your vibration levels are really high, at 1 minute for example…this is really bad.

other thing, is analyze if happens when you change the fligth mode for example , because when you change, the sensors change too.

Auto Analyses feature help a lot too, if there is something wrong is a problem.

You can start looking

  • Mechanical Failure
  • Power Issues
  • Attitude/Attitude Control
  • IMU Consistency
  • Sensors…

That is good that you are not use Q-brain:grinning:
Other than crash, your vibration level is good from 4miniutes to 5minutes. However the vibration level from late 5miniutes is horrible.
How do you mount your NAVIO ? Do you have cushion mount or something?

I used these on the back of a 3d printed raspberry pi/navio case:

But… I think I might have possible found the real issue. One motor doesn’t seem to be spinning as fast as the others. I carefully did a motor test and it seems that at around 30% throttle, there is noticeably less movement to the quad when I test that motor with propeller as the other ones.

Also when I was outside testing again, it seemed like I couldn’t see the other blades spinning, but that one I could still kind of see it. If that makes sense.

Anything I should try before asking for a replacement motor?

Would one motor spinning slower cause the wobbles?

do calibration with apm

which calibration?

recalibrate all ESCs , using APM. (WITHOUT PROPELLERS)

  1. Push the throttle to maximum (first),
  2. Power on Navio and wait the APM start.
  3. Turn off the baterries
  4. Power on Navio again and wait the APM start.
  5. Push the throttle to minimum (sound beeps)