Navio2, Ardurover, PPM input lag

Today I put my Navio2 in my rover. I use my Graupner Hott TX/RX with it. The Graupner RX puts out PPM, but no SBUS.
The rover is nearly uncontrollable, because there is a severe input lag. At first I thought it may be a problem with wifi, despite it worked fine with the original Navio and Graupner. I removed the wifi dongle, but the lag is unaffected.
If I move the stick all the way forward and back to the middle again, the rover does not react at first, then it shoots forward at full throttle and stops again. I am running ArduRover 3.0.0 from emlid.

Now I took a X4R SB receiver out of one of my copters and voila, no more input lag with SBUS.
Still the rover worked without a problem with original Navio and PPM…

Could you please upload a log with PPM receiver? We’ll take a look.

Here is a short log file with Graupner GR12 receiver, channel 6 set to SUMO (Graupners version of CPPM), transmitting 6 channels: (1.7 MB)

And a log with FrSky X4R SB (SBUS and CPPM firmware) using CPPM: (1.0 MB)

As expected, there’s nothing suspicious :slight_smile: Do you have another PPM receiver to test with?

How many different RC systems am I supposed to own? :slight_smile:

I already tested with Graupner and FrSky CPPM. Both with the same result. FrSky SBUS is fine.
I just made a video of the problem. It is uploading to youtube right now.

@schuermannsebastian sorry, missed the part about FrSky CPPM, two is enough. Waiting for the video.

First video shows the CPPM problem, the second video shows a startup problem I have and the rover working fine with SBUS:

Thanks for the videos, we’ll try to repeat the issue and see what we can do about it.

We were not able to reproduce the issue with Navio2, ArduRover 3.0.0 and FrSky CPPM. The response time is the same for SBUS and CPPM on our build.
Can you upload your parameters file? Or what would be even better is an image of your SD card.

2 posts were split to a new topic: Navio2 and Frsky D4R-II ppm input lag in Mission Planner

Better late than never… Here is the SD-card image I had the ppm problems with: