Navio2 and Frsky D4R-II ppm input lag in Mission Planner


as I am progressing with my navio2 setup (i managed to use wifi for transferring video and telemetry so far), now i continued with the setup of radio input. I am using FRSKY DJT module on my Turnigy 9XR pro and FRSKY D4R-II receiver. I did connect CH3 and CH4 of D4R-II with a jumper and correctly binded my DJT transmitter and D4R-II receiver. But when I go to Mission planner radio calibration step, as you can see in the uploaded video, i have a huge lag…

Initially, i was connecting my NAvio2/RPI2 to mission planer through a wifi dongle using UDP connection type. I thought that my D4R-II was interfering with my wifi dongle because both of them work in 2.4Ghz…
So, i removed the wifi dongle and tried connecting my Navio2/Rpi2 to mission planner through my radio telemetry (hobbykings 433Mhz) modules. You can see my connection setup in the attached image… However, the Radio control lag continues to exist…
Could you please help me ?? why does this happening ???

It seems like telemetry issue to me.

  • Could try controlling a device directly

Connect an ESC with a motor to a RC receiver output with a corresponding channel number (I presume, channel 3 is used for throttle control). Check if the lag persists. This setup doesn’t need any code running on Raspberry Pi whatsoever.

  • Wire everything up as it had been before (PPM/SBUS <-> PPM/SBUS on Navio 2). ssh into your RPi and disable ArduPilot (if it had been enabled) and run this command watch -n0 cat /sys/kernel/rcio/rcin/ch2. Move a throttle stick and observe.

Dear George,

here is my feedback to your proposals…

  • I connected my DJI Opto ESC to the motor and the receiver. However as the Opto ESC cannot power the receiver, I used also a separate BEC in order to power the receiver. In this video you can see that although the first initial input takes some time to reach the motor, then the response of the motor is almost sudden according to my inputs (turn on volume to listed the motor sound. Ignore the rest ESCs beep sound)… I think that this behavior is normal… Isnt it ??

  • THen i powered back everything as it was shown in the photo of my previous post. I logged in to RPI2, i stopped the ArduCopter process and I executed your command sudo watch -n0 cat /sys/kernel/rcio/rcin/ch2 As you can see in this video the response according to my inputs is almost sudden… SO what is the problem with mission planner showing such a lag ??? As i told you in my previous post i tried using as telemetry both the UDP service through wifi and also the COM service ( -C /dev/ttyUSB0 command in navio) using a telemetry radio connected through microusb to RPI2.

Please guide me for my next steps…

Thank you

It is mission planner error in the calibration process.
It also occurs to me with the original pixhawk 3dr.
Do not give more importance.

1 Like

@drone_newbie there may be a lag in passing the RC input values over the telemetry which you see in the Mission Planner, this is normal.