Navio2.....0 volts on software...but 5V everywhere is ok

not sure what the deal is, i had my navio2 sitting for couple months awaiting my new build now using an Rpi4 and latest emlid-raspbian image.
So both the navio and rpi4 turn on ok, the green led comes on the navio but it goes off when linux is finished booting…
as soon as I launch emlidtool it tells be 0.00V at board, and the ADC tests the same…but there is verified 5.1V at the power module input AT the navio connector itself, so power is going in just fine, i also have 5.1V at the rpi4 5V pins, there is also 5V at UART port so there is power and the board seems fine, not overheat or anything…is just the software insists there is 0.0V at board…
not sure what else to try, have tried to power modules and doesnt help, neither powering the rpi4 on its own power source either…

Help!

Hi @iriol,

Could you try to power Navio2 via a mini-USB port? Is it possible to launch ArduPilot in such a setup? It’ll help us to understand if it’s an incorrect readings issue or something else.

My navio2 doesnt have any mini-usb port, did you mean via the rpi mini-usb? I have done that and there is power going into navio2 but i cant launch ardupilot as the board checks fail

What if you try to start ArduCopter bypassing Emlidtool? You can use this command:

pi@navio: ~ $ sudo systemctl start arducopter

this is in the emlidtool (top) and the other is starting the executable directly (bottom)

Hi @iriol,

It looks strange that so many tests are failed. I believe reflashing from scratch may help. Have you tried to reflash with the latest stable image from docs? If not, may I ask you to check it?

If it doesn’t help, please provide me with the photos of your Navio2.

yes i have used a couple different SD cards using the latest image and isue persists…

Could you please share the photos of your Navio2 with me?

here you go, sorry was gone last week. the stuff you see around barometer is non-conductive glue that is leftover there for holding down small foam I had over baro for standard reasons.

i forgot to add, when i start emlidtool it keeps asking me to update RCIO, which I let it do and it completes fine, then I reboot, then it asks me again…if I skip then you can see on the info screen the failed components

Hi @iriol,

Thanks for the photos. We’re looking into it. I’ll write you back once there is any news.

Hi @iriol,

Please check your PM. I’ve written to you there.

UPD. I’ve converted the thread to PM as we might need some sensitive information during the investigation.