0V to software, but 5V on board

I’m having the same issues as the related post I’ve linked below, and have taken the same troubleshooting measures to determine if it’s the same issue. I also get 5V at all the UART ports and receive all the same errors and symptoms posted here. I am using the latest image in a Raspberry Pi 4 with a Navio2 hat. I do not have anything connected to it at the moment, but the Raspberry Pi 4 is plugged into the wall with a 5.1V / 3.5A power supply. I also tried with a 11.1V battery (through the power module). I can attach images if necessary, but nothing stands out as appearing damaged or fried.

related thread

Hi Ethan,

Welcome to the forum!

Did the device behave this way from the beginning? Please also share the screenshot of the emlidtool test.


This is not a new device, it was used by a university group before mine, so there is a possibility of damage, but none that I can see. Freshly flashed operating system as well. I had already tried that in hopes it would help. Here is the emlidtool test as well.


Let’s try to reflash the SD card with this image. Please be aware that it will erase all the previous settings.

  • Do you have another Raspberry Pi to test your setup?
  • Can you also share the photo of your setup?
1 Like