Navio+ with AC 3.4.0 - Compass Variance


I was using Navio+ with AC 3.3.3, but I had to upgrade AC in order to use Reach. In the previous version I got the following values for the compass calibration: x = 274, y = 98, z = 13. Now, I get X = 414, Y = 107 and Z = 139 (I did calibrate several times and I always get values around these ones). Furthermore, the flight is unstable and it appears the message “Compass Variance Error” several times during flight. I tried several 3.4-rc versions and I had the same problem with the compass.
Could it be a problem with the new AC version?

Thank you!

And what about the latest stable i.e. 3.4.3?

I get the same compass calibration with the stable version here (the .elf file though is V3.3.3. and this can be confusing…).
I will try to fly it and see if it is still unstable.

Okay, for some reason Navio+ binaries haven’t been updated on build server. Could you please build a binary by yourself and give it a try?

I tried the stable version and I am getting almost the same values for the compass calibration. During flight the UAV is unstable except in Loiter.
I noticed that in AC 3.4.3 the magnetic field is quite high (around 450-500), whereas in AC 3.3.3 is around 300 (I measured this value after calibrating the compass with both versions and with the flight controller at the same place). Is this normal?

These are the logs 4 11-12-2016 1-21-28.bin (3.9 MB)
5 11-12-2016 1-31-07.bin (1.8 MB) (the first one is using Reach as well)

I would really appreciate some help.
Thank you in advance :slight_smile:

There’s a possibility of magnetic interference on your frame.
I suggest trying out CompassMot or/and hooking up an external mag might also help.
An external compass is the easiest solution.
Have you adjusted PID values? Parameters file can be also of help. Thanks.

I think it’s not magnetic interference since with the flight controller located at the same place I get “normal” values of magnetic field with the old AC version whereas I get high values with the new AC version. Since hardware is the same I guess the problem is with the software.

Did someone use Navio+ successfully with the newest AC versions?

BTW I selected “internal compass” when calibrating the compass.

Magnetic field units have changed between versions. That’s why you observe different values. They can indeed be bigger.

I didn’t make up an assumption above out of thin air. Any time you give an engine throttle without taking off, magnetic field values become noisier. This is a symptom of an interference that is to be gotten rid of. Either with an external mag or CompassMot.

AFAIR, you have only one compass at the moment. That is indeed internal.

I tried both versions today again. With AC 3.3 the flight was really good but with the new AC 3.4 it just crashed when taking off… Did anyone try Navio+ with AC 3.4? I just can’t believe that it’s perfect with old version but useless with the new one.

Just in case I have made a mistake, these are the parameters of both versions: (6.1 KB)

Would it be possible to provide us the AC 3.3 version with ERB support?

Thank you.

We’ll get to the bottom of this issue ASAP. Sorry for the inconvenience.

We’ll need some onboard logs, actually.

Did you purge old parameters between switching the versions?

Log from today crash is here 2016-12-22 12-24-19.log (1.5 MB)
and the ones from the other day have been already posted.

To switch the version I just changed the microSD card (I have different cards for different versions). Should I have done something else?

Thank you for your help and let me know if you need something else.

1 Like

your compass values seems to be influenced by either cables from battery to esc/motors or your motors;
did you fly/crash in stabilize mode?
how do you protect your barometer? can you provide a picture of your setup?

1 Like

Sorry for the delay but I was not able to get the picture before. This is the setup (it works good for old version):


The crash was in stabilize mode. Barometer is protected with a piece of cloth (similar to the one shown in Docs section) fixed to the case.

Thank you!

Hi mariagf,

Could you please reset all the parameters and calibrate everything (accel, compass, radio) once again?
Also it’s necessary to reajust PIDs. Please do not use old PID parameters.

If the problem is still there, please provide detailed description of UAV’s behavior during the flight and attach new logs and parameters.
Video of the flight would be really helpful.