Navio+ Power Module Problem

Hi all,

I’ve some problem with the Power Module v1.0 from emlid. When I connect it to the power port of the Navio+, the RPi2 and Navio+ booting normaly, but when I start the ArduPlane, the APM Planner battery monitor voltage and current just shows as 0V, and the current negative.

Is there something to do?

My test: Rpi2 / Navio+ / PowerModule V1.0 / Battery 2S 1050mah

APM Planner:

Battery Monitor set as “Pixhawk Power Module 90A”

Mavlink monitor:


Hugo Andrade.

Did you restart the APM after setting the battery monitor confiration? Restart is necessary.

1 Like

Hi Mikhail,

yes, I tried to restart APM, but the Monitor still show the same measurement. I tried to restart the Rpi2 and Navio+ and continues the problem.

Hi Hugo,

Can you try running this commands and posting output? With battery connected.

 cat /sys/kernel/rcio/adc/ch0
 cat /sys/kernel/rcio/adc/ch2
 cat /sys/kernel/rcio/adc/ch3

After that we will be able to tell whether it is hardware or APM issue.

1 Like

Hi Igor,

I tried to running this commands, and this is the output:

My bad, that was for Navio2 :grin: Sorry about the confusion.

Can you open the full parameter list and post here these:

BATT_CURR_PIN 3.000000
BATT_VOLT_MULT 12.020000
BATT_VOLT_PIN 2.000000

haha no problem. I set the parameters, but the problem still the same :expressionless:

Did you reboot after setting the parameters?

Yes, I rebooted… and then starts to show the negative current.

But the voltage is still zero?

Hugo, can you turn off APM and check how is the ADC functioning. Here is the example. What is the output when you run this example?

Yes, the voltage is still zero.

The output of this example is:

Igor has another test I can do?

It is likely that you have a faulty power module. We will ship you a new one. Please PM me your order number.

A post was split to a new topic: NAVIO2 Power Module readings in APM Planner show zero