Navio not powering up when i connect with ESC

Navio is not at all powering up when i try to connect it with the esc module. But its powering up when i power it via raspberry pi via usb cable. Help me solve this problem. @igor.vereninov

@Sathish_Kumar please provide a photo where we can clearly see how ESC is connected to Navio.

Maybe you just have a OPTO ESC, these ESC’s don’t provide power via the servo lead, you would need to use a seperate BEC

When i tested the esc it with multimeter its giving output of 5 volts.

Could you please connect only one ESC and see if Navio powers?
Also, does it gets powered if you connect the power module without ESCs?

no i tried it… its not powering up

What about the power module?

but if i power it raspberry pi its powering up… i dont have the connecters to test via power module

What do you mean? I see that you have a power module with the cable.

ya sry… now i tried it … its powering up…with the power module…
But there is no power comming out in ppm… for the ppm encoder

Navio+ does not output power on PPM encoder from a power module. You still need to connect BEC to the servo rail for that.

Be careful, there’s a chance that you have a short circuit.
Disconnect all ESCs and other devices from Navio and PPM encoder.
Try to power PPM encoder with an ESC directly, does PPM encoder work like this?

now its not powering up… let me check and update you… thanks

Your cabling looks really odd. On the picture I see servo connectors only occupying 2 of three pins and the connectors are plugged in opposite orientations.

It also looks like 12v+ is going directly to the servo rail in the 1st picture? Or is the picture playing tricks on me?

Definitely make sure you have only 1 x 5v+ connected to the rail. Anything else will cause problems…

Smartphone again…
I now could recognize what you did @Sathish_Kumar. You turned the connectors around to only connect the signal pin of three ESCs. On the Smartphone it looked like only one pin was free. Sorry

ya i have connected only one cable. for other 3 esc i connected only signal wires.

so it is not at all powering up the ppm encoder so . connected ppm encoder to the esc power and signal wire to the ppm in navio. But there is no signal showing in my apm planner and also tried to use ppm decoder in navio examples its giving me the output of 0. What can i do is there any way to fix it.?? @mikhail.avkhimenia @igorvereninov @schuermannsebastian

Need your Support Please . Still no reply… @igorvereninov @schuermannsebastian @mikhail.avkhimenia

I never used a ppm encoder. I would use a multimeter to check all connections from the power source to the load.

It’s a little bit hard to understand what is going on, but if PPM encoder is not powered by a BEC from the ESC then something is wrong with one of those two (or both).

Could you please check once again step by step:

  1. Disconnect everything.
  2. Connect 3-pin connector from an ESC to the PPM encoder. Does PPM encoder gets powered?
  3. Please provide a photo