Mobile Data usage with AT&T


I have an ATT sim card in the RS2+ but when i try to activate the “Use Mobile Data” radio button, it goes back to disabled:

when I hit it, it will change color and show the:

for a few seconds and than change back to what I have in the top picture.

in the top you can also see that I get signal and I test the sim card with a access point I have to make sure the card is working.

Hi @guyz,

I suppose your SIM card is working since you get FLOAT, which means the correction is incoming. So most likely, you get some corrections over the Internet. Are there any issues with the signal when the toggle turns off itself?

Some SIM cards require enabling the Data roaming option to connect to the network, so please make sure it’s on.

Additionally, please send us the Full system report from the device to I’ll dig into this to see what could be the reason for such behavior.

1 Like


The correction were coming in on Wifi I used when trying to set it up to use the sim card.

I have the Wifi at the office but out in the field I am flying drone on 2.4Ghz so can’t use it for Wifi that is why I try to gett corrections over the Sim card and connect the base to the PC over serial and eliminate the 2.4Ghz Wifi.

Can the base take 5Ghz Wifi via USB OTG? might solve my issue as well.

already sent the full report few days ago see ticket 77989

Are you using an Autel UAV ? If so, you can use Emlid’s guide

If nothing else, you can just set your base up and fly your mission and post process all your data.

Thanks Bryan, but I am using something else and want to get RTK in-flight

1 Like

I see. I’ll check your Full System Report.

In the meantime, please turn off the unit’s Wi-Fi access in Emlid Flow, then try to turn on mobile data in the Mobile data section of Settings.

Can the base take 5Ghz Wifi via USB OTG? might solve my issue as well.

Instead of this, I suggest you put your SIM card into a mobile device and connect your Reach to the Internet via mobile hotspot.


Hello Guy,

I’ve also been unable to use the AT&T SIM card in the RS2+ noting that this SIM is for DATA ONLY. Is your AT&T SIM for voice/data? Or is it for only data?

I’ve been trying for more than a week to get this resolved, and I believe that we’re possibly making some headway.

Here’s the last word that I received on the matter from Liudmila with Emlid support:


On 7/12/2023 9:03 AM, Liudmila S. | Emlid wrote:
Hi Kelly,
We checked everything with the devs. At the moment, it seems that this SIM card doesn’t activate the internet in RS2+ because it works on the data-only plan. A couple of users with AT&T SIM cards couldn’t get the internet while their plan was data-only. One of the users reached out to AT&T support and they were able to mimic a hybrid data/voice plan, instead of a standalone data-only plan. After that, it started working. So I can suggest checking with the provider support whether they can do that for you.
Thank you!

Liudmila S.
Application Engineer

It’s unclear if Emlid could fix this from their end with a firmware update, so until then, we’re hoping that AT&T will be able to somehow re-provision the SIM card that I already have.

Fortunately, the great folks at Data Activation Center (DAC) have been working on a solution and plan to meet with representatives from AT&T next week and to possibly resolve this issue related to the RS2+ not being able to use a SIM with a data only plan.

Here’s the skinny on the modem that’s in the RS2+ that’s currently still holding my nano SIM:

1 Like

Hi Kelly,
I will keep you posted on the SIM card plan update.

1 Like

Thank you so much Chandy!

this won’t solve the issue, i am trying to eliminate all 2.4Ghz RF since the drone uses it for command and control so all other elements that will use it in the field will reduce my range.

@zoltan.biber can the RS2+ take and 5ghz wifi module via USB OTG? or even wired ethernet?

@c-dac @vkbellis I tried today with another sim card that has a regular plan with data not data-only and it works with ATT, question is how can we get it to work with data only, is that a emlid issue or ATT issue. not sure. @zoltan.biber can you check if it is a firmware issue?

1 Like

Or possibly it is a question for Qualcomm?

@guyz Thank you for testing this Guy. Were you testing it in the RS2+ with its recent firmware update; i.e., 30.2?

@vkbellis I am still on 30.1 for the RS2+

FWIW - I just tested RS2+ on firmware v30.2 and the issue of being unable to use the AT&T data-only SIM with the RS2+ persists.

question is how can we get it to work with data only, is that a emlid issue or ATT issue. not sure.

We’ve only seen such behavior in rare cases with some AT&T SIM cards. But it’s hard to tell the reason right now. At the moment, I can suggest the same as Liudmila in her email: Please check with the provider support whether they can mimic a hybrid data/voice plan instead of a standalone data plan. We have a user who faced the same issue, and this solved it.

can the RS2+ take and 5ghz wifi module via USB OTG? or even wired ethernet?

We haven’t tested it yet. Also, we have many other users with drone setups, and they work well with Reach RS2+ using a Wi-Fi connection, so overall, this setup should work fine.

Wait - are you saying that you have seen AT&T data-only SIMs working with Emlid equipment? Or you saying that you rarely see data-only AT&T SIMs?

I just wanted to say our users rarely face issues with the SIM cards, and usually, it’s something from the setup side. But we’ve also seen a few cases where the reason was in data-only SIM cards.

Thanks Zoltan!

Understood… I think, but you tell me if my understanding is correct or not:

  • Users’ AT&T SIM cards routinely work - ALL cards that work with Emlid equipment are voice + data type SIMs.
  • Rarely those users have any issues, and when they do, usually it’s related to their Mobile data configuration in Emlid Flow.
  • Data-only AT&T SIM cards don’t work with Emlid equipment. Emlid users are advised not to get data-only AT&T SIM cards.

Like Kelly, I too am having the same issue. I have spent a couple hours with my AT&T rep trying to make this work, as well as Emlid support and DAC before that. If you have any suggestions as to the type of plan (other than just data + voice), the type of device that AT&T might try selecting as that affects the provisioning from their end, and any other settings that AT&T should try, I would much appreciate it. I am beginning to wonder if I may have a faulty unit instead of an AT&T issue.

Our receivers work well with different types of SIM cards. In most cases, we can solve similar difficulties by changing the Mobile data configuration, as Kelly said. We’ve also looked into some reports about AT&T SIM cards and didn’t see any issues with the receivers themselves. So we don’t know about any specific reasons that would prevent Reach from working with an AT&T SIM card because it’s data-only. But we’ve seen some cases in which using a non-data-only AT&T SIM card helped users who worked with a data-only SIM card before. So if changing the settings doesn’t help, it can be a possible solution.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.