Mobile data does not want to turn On in Emlid Reach RS2+

Hi all,

We inserted a SIM card in the Emlid Reach RS2+ receiver. When I am in Settings → Mobile Data the switch Use mobile data does not work. It stays turned off.

How can this be changed?


A post was split to a new topic: RS2+ SIM card connection issues

Hi Hanno,

I’ll need a bit more details to see what can be wrong:

  • Is the SIM card defined in the Status bar?

  • Does the SIM card support GSM?

  • Have you tried entering any APNs?

This is one of the problems I am having with the RS2+ units. I finally got it to work Friday but not sure how. I first turned off and back on data roaming. It showed “on” and then it turned back off. I am pretty sure when I turned off wifi it began to work?? I was using the Nrtip caster so ti worked the entire time once it was on.

My base unit was on the entire time. But my rover is what gave me fits. Once mobile data was on, it was fine. Both units are up to date running FW 30.

The 3rd SIM card worked. Not ideal. But at least it works now.

Hi Hanno,

I see, thanks for the update!

As I know, my colleague Polina is in contact with you regarding this issue via email. Please share the details about the SIM cards used with her, and we’ll look closer into it.