Emlid

Community Forum

Mission Planner connection problem


#1

Hi, I’m a beginner in drone.

  • Image version: emlid-raspbian-20190227
  • ArduCopter on Navio2: 3.6
  • ArduCopter on Mission plannner: 3.6.5

Hardware:
Navio 2 + RPi 2 B
telemetry: FT232R 433mhz

I met a problem of connecting Navio2 in Mission Planner.
I could connect Navio2 at sometimes (most after restart ArduCopter on Navio2), but I was always disconnected from it after connecting for a while.
And if I restart ArduCopter in Navio2, sometimes it will be connectable for a while again, sometimes not.

Please see the video here for details.
https://youtu.be/EP1M67h43KA

I tried to use UDP and 3DR radio telemetry, and got the same result.
It makes me can’t calibrate anything in mission planner.
Could you help me to debug? thanks!

Other info:


(Gleb Gira) #3

Hi @stella,

May I ask you to change the UDP port to 14550 and comment with ‘#’ the line /etc/default/arducopter?


#4

Hi gleb,

Thanks for your reply!
the line “/etc/default/arducopter” is a mistake when I took the snapshot.
In the file, it doesn’t exist.
I will change the UDP port to 14550 and reply the result, thanks!


#5

Hi gleb,

I changed the UDP port to 14550 it seems more stable but I was still disconnected from Navio2 after connection for a little time.

If I connect ESC line to Navio2, I will be disconnected from Navio2 in a short time and ESC keep beeping.

Could you help me?
thanks!


(Tatiana Andreeva) #6

Hi @stella,

Could you please describe the behavior of RPi and Navio2 LEDs when the connection drops?
Does the ssh connection to RPi intermit as well?


#7

Hi tatiana,

Please see the video:
https://www.youtube.com/watch?v=H2cZGkmqiew&feature=youtu.be

The esc kept beeping as soon as connection dropped.
And the ssh connection was still well connected.
Thanks.


(Gleb Gira) #8

Hi @stella,

Can I ask you to send here the output of these commands after connection drops?

journalctl -u arducopter
systemctl status arducopter.service

Also, please share some photos of the hardware setup. Try to disconnect drone’s hardware, leave only power for Navio2 and see if the issue still occurs.


#9

Hi gleb,

I tried to reinstall the OS of Navio2, and I was still in stuck.

The output result:

I tried to disconnect drone’s hardware, but the issue still occurred…

Here are some photos of hardware setup:



On the other hand, I found I couldn’t update firmware ArduCopter V3.6.9 to navio2 with mission planner, it showed following messages:

Even though I could connect Navio2 with UDP.

Thanks.


(Marc Lebret) #10

There is a big problem here:

45

Your wiring color code is disturbing (receiver to Navio2). Verify that signal line from receiver (not ground) is well on the top line of Navio2 pins.

ESC plugs are reversed (top to bottom). Signal is orange, ground is brown.

Normal, you cannot use mission planner to update your arducopter software.

When you will be OK with 3.6.5, have a look at https://community.emlid.com/t/navio2-arducopter-upgrade/10743

There were some changes in the Emlid file structure but you can edit some lines and do it.

Marc


#11

Hi Marc,

Thanks for your reply.
It’s my fault when connect all the wires to Navio for taking photos.

And I upgrade the firmware to V3.6.9 successfully.
But the problem is still exist…

Thanks.


(Gleb Gira) #12

Hi @stella,

Is there a possibility to test MP on another PC with a connection through UDP? You can also try QGroundControl and see if the issue also occurs there.
Also, can you recheck if both telemetry radios use the same configurations?


#13

Hi gleb,

I tried

  1. test MP on another PC with a connection through UDP/telemetry
  2. QGroundControl with a connection through UDP/telemetry
    https://youtu.be/hVinTGLAYMg

but still always lost connection.

I found that if the LED on Navio2 turns to solid yellow or no light, I will lost connection from it. I don’t know what the two conditions mean with the description of the link. http://ardupilot.org/copter/docs/common-leds-pixhawk.html#LED-Meanings

I am not sure if something wrong with my Rpi board so I have booked a new Rpi 3 Model B+ board, and will try it when I get it.

Could you give me other ideas to solve it? thanks.


#14

Hi all,

I test it on a new RPi board without connect any other thing through UDP and telemetry radio, but I got the same issue…

I found there is almost the same condition with me

May I ask what’s wrong with the NAVIO board??
Is it solved now?
I waste almost 2 months on this issue …

Thanks.


(Vitalie Cartera) #15

Issue was resolved by replacement of the board.
You were as lucky as I.


#16

Thanks your quickly reply!
If that, I think you are more real lucky than me… QQ


(Gleb Gira) #17

Hi @stella,

Did you have successfully connections earlier or the issue appeared from the beginning?

Can you please try the previous version of Raspbian image? You can reflash the image using this guide.

We are still trying to figure out if it is the hardware or software issue, so it is important to do this last test.


#18

Hi gleb,

Thanks for your reply.

I tried the previous version you posted.
Met some problems in
sudo apt-get update && sudo apt-get dist-upgrade


And I tried reflash image and successfully use pip3 install emlidtool with this command at first.

I don’t know if I have to update or not so just both of them.
Unfortunately, I got the same result…
lost connection when the LED turns to solid yellow or no light.

This is an error message during apt-get update command.

I’m not very sure if the issue appeared from the beginning or not because I just can’t connect NAVIO2 with MP in first several times. After I could connect it, I just stuck with the issue.

Thanks.


(Tatiana Andreeva) #19

Hi @stella,

Can you please reflash the SD card once again with the image @gleb.gira shared above?
Don’t run sudo apt-get update && sudo apt-get dist-upgrade command after reflashing.

Then please try to connect it to MP once again and report us about the result.


#20

Hi Tatiana,

I don’t know if I have to update or not so I have tried that, and also the same issue appeared.
Thanks.


(Tatiana Andreeva) #21

@stella,

Could you run emlidtool and post the screenshot of it here?

Do I understand correctly that you reflashed the firmware without updating? Could you clarify which issue do you mean?