Missing Events inVer 2.5

Hi, I have upgraded to reach ver 2.5 and it is missing camera events. Tried different cabling etc etc over a couple of flights with the same result. I conduct a lot of UAV mapping with no problems at all with the older versions. I had to reflash back to an older version (2.3) out in the field and it all started working again.

1 Like

I had a similar problem yesterday. Only 345 out of an expected 383 event marks.

I would really like to be able to pull out the time stamps directly from the .obs file, to eliminate other causes and get a definitive count for the time stamps.

If the Emlid RTKpost is not able to get a solution for a timestamp it skips that event in the output, which causes issues if not enough data was available for RTK float or fix solutions. I have been combining the kinematic results with event messages from processing in single mode, which has always up to now produced a full set of time stamps.

@igor.vereninov did state:

‘As a workaround you could get a full list of events by searching the .obs file for " 5 0". I can see 344 events in RINEX file that you have uploaded.’

in this thread, but I do not find that string in my .obs files?

Either way, it would really help when trouble shooting this sort of issue to be able to extract the event time stamp data directly. Even with poor satellite logs useful geotags could then be reconstructed by interpolation.

Before the latest update, the time stamps did not miss a beat, every photo was tagged even over large datasets. When I convert the rover log to rinex, I can see quickly how many events it recorded and I was missing 100 events over 1000 photos. Something has happened in the 2.5 update.

We have updated FW on the receivers and this likely caused the issue that you are seeing. Can you please share your .ubx log files and how many event they should include? We will check if this is receiver config issue or conversion issue.

You can post logs here, or mail to support@emlid.com.

raw_201704231417.zip (3.0 MB)

I was expecting 383 events from this flight.

Many thanks

I see no events in this .obs file, can you upload the original ubx? When you test events in Camera tab, do they work?

apologies, selected the wrong file.raw_201705211334.zip (3.4 MB)

Camera events work as expected on the ground, always check with a test image before flying…

raw_201705162307.UBX.zip (8.1 MB)

Hi, I was expecting 1097 events in this log. Thanks Kyle

Can you explain what you mean by ‘events in camera tab’

You can see last time mark in “camera events” as shown here:

Useful for testing.

We will look into the issue, thanks for the reports and logs!

Thanks very much - any chance you could explain in a bit more detail how to locate the event marks in the .pos or .ubx file? Cheers :slight_smile:

In UBX look for TIM-TM2 messages, the protocol is binary so please refer to UBX protocol description for more details.

In pos you will have a separate _events file after processing where you will have all the coordinates for events.

In RINEX obs you should look for “new site occupation” flag, which is a line with epoch record ending with " 5 0"

Thanks very much - when I load the RINEX .obs file into excel (or notepad) and search for the string " 0 5", I don’t find any hits, though I know there are events recorded in it.

Apologies, I’m sure this is something simple but has me scatching my head. Is the epoch record line something like this?

2017 5 21 13 39 16.0020000 0 16

Never mind - can’t understand why searching that string doesn’t work, but as pointed out in the other event mark thread, when processed with rtkconv the stats displayed show the number of time marks (T xxx). Have now identified a likely intermittent connection problem, hopefully all now working correctly. cheers :slight_smile:

My bad, it should have been " 5 0" (two spaces between 5 and 0).

Please let us know how it goes so that we can decide whether to keep searching for an issue on our side.

Hi Kyle,

I actually checked the raw log without RTKLIB and it only contains 907 time marks. Some of them are discarded later, leaving 874 valid points. Is that what you got with our RTKPOST?

Is it possible you have had something electrically wrong with the setup on your side?

I will check if everything is fine one more time, though.

Hi Egor, yes that is correct, RTKCONV reported 874 points and I captured 1097 photos. This happened twice, after the 1st flight I changed out all the trigger cables etc etc but it was the same on the 2nd flight, I then reflashed out in the field back to Ver 2.3 and it started to work perfectly without making any further changes to my setup. It has not missed a mark since running the old firmware.

Hi Egor,

I have only 461 out of 507 time stamps from a flight yesterday. The issue which I thought might have caused the problem (hotshoe connector not fully tightened) has been corrected, and the event logging has in any case always worked before on this rig. Raw log file sent.

I will flash back to 2.3 and carry out a test flight.


Currently looking through the log, thanks for the update.

This will likely change nothing, as the main difference is the receiver firmware we’ve updated recently to add Galileo support. Unfortunately, you can’t undo that. I continue the investigation.

1 Like