Mettatech PPK issues

Hi,
I had previous tried a Tuffwing PPK kit /w M+ on my Phantom 4 Pro V2 but with no luck. I kept getting alot of noise, even with tin foil wrapping and setting changes. They didnt offer much support (but this forum was awesome).
This is to document issues I’m having with the Mettatech, which are far less problematic.
I have had great support and communication from the guys at Mettatech and they are continually improving their documentation.

I used to get the majority float but now I’ve got 0.6% Float, the rest it fixed and I suspect the float is because I let the drone fly too early.
My major problem now is that I am 4 trigger too many… I have 699photos and I need 703.
I am using Emlid Studio - what can I do?? I got sneaky and just copied a three photos but when outputted, no photos had geotags. I had this issue with Tuffwing too - what am I doing wrong?
I did do 3 battery changes?
Joe

2 Likes

Every time you change batteries on the Phantom 4 Pro and turn it back on that triggers the strobe light which in turn triggers an event without a photo. You need to go into the events file and remove those events BEFORE you image tag the photos. They are easy to find since their elevation will be on the ground.

Thank you. Makes total sense. For anyone reading this, the .events file is outputted from the PPK software. Use notepad to edit it.

I got the photo count and the events to match, but when I went to use them in Dronedeploy, no metadata was found, but at least I’m one step closer. Any solutions?

Here is a link to the project folder with unmodified photos etc.

[Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.](https://Compound Backup)

I have the base (RS2) and M+ on GPS, GLONASS and QZSS at 5hz.

I am not having much luck with Studio once I “successfully” post process the GNSS data and burn the image tags. I am working with a trial version of Agisoft Metashape and they have a method of importing the EXIF data of images and this feature does not work when using images tagged from Emlid Studio. However, this same feature is successful when I import the same images tagged from my trial version of Topodrone TopoSetter post processing software. So I suspect there is some type of issue with the Studio image tagging process.

Thank you, it worked in Redtoolbox.
Uploading now, lets see what the accuracy is.

Joe what mapping software are you using to process your images?

David
dronedeploy, also use emlid studio and redtoolbox.
I do volume stockpile measuresment and cut and fill.
Don’t highly rate dronedeploy for this, but its pretty good. 6/10
what do you use?

If Studio also gives you a list of image ids and coordinates in .txt or .csv you can import that as a "camera reference in Metashape. That would override the image exif.

RedToolbox rewrites the image exif and provides a coordinate file. Both work fine with MS.

1 Like

I have been utilizing WebODM for a couple of years. I recently completed trial versions of Pix4dMatic and DroneDeploy and am currently evaluating Agisoft Metashape. Once my evaluations are complete I’ll make a decision and hit the “Buy Now” button. Let me know what you are getting for accuracies with your PPK kit.

Studio currently only provides an event file with timestamps only and no photo image names associated with the coordinates. TopoDrone/Toposetter can provide that txt or csv file. My experience with RedToolBox was that it did not fix many of the early events in the flight and there was no way to process in the events in a combine manner as you can in Studio.

I’ve had projects where do to the nature of the CORS rinex file being v.2.x rather than v.3.x and antenna limitations caused problems with the corrections when including GLONASS; some percentage of FLOAT mixed in with the FIXed events. Rejecting the GLONASS constellation resulted in all FIXed. Probably not related to your experience but just tossing it out there.

I’m not sure what you mean by “in a combine manner” ? Some combination of observation files for one project? My experience is with an Autel RTK drone which results in only one set of files.

1 Like

Here is a screen shot of the custom settings in Emlid Studio. The “Combined” filter processes forward…then backwards to Fix the early epochs that are originally Float solutions. I just downloaded another version of RedToolBox and it looks like it now performs this type of combined filter…although there is no way to make this selection in the settings.

This look pretty standard to me. Like Dave said you might think about what constellations you are running and check the satellite status to cut the worst constellation. In our case the western region of our area for whatever reason is terrible with GLONASS. Personally I think it has to do with all the lakes and the subterranean minerals. You can bring the mask down to 14-13-12 to see if it makes any difference at all but it’s unlikely.

OK, I have some data.
Yesterday, I flew three large flights. All of the flying went OK, no major issues.
Unlike with the Tuffkit, my drone had no problem getting enough satellites to get going and with the battery add-on to the Mettatech kit, I didn’t have to wait for it to boot up after every battery change. Thats the good news.

The following will cover the simplest, most fixable (in my opinion) flight. Once I get a fix for that, I’ll put the other two up after trying to fix those. I know a few people are following this now, so I’ll try and be thorough.

Flight 1: Northern Pits


image

I flew at 4m/s (keep the speed relatively low especially when using a M+ rather than a M2. If I get this working, I’ll be upgrading.

I processed my RINEX base and M+ logs through studio:


The results are encouraging.
99.7% fix, 0.2% Float/, 0.1% Single.

I am 3 photos short in my folder, ie my events log shows I have more triggers than I actually have. These are from turning the drone on after battery changes and from turning it off.
Going into my .event logs I removed any triggers from the ground level (three of them).
image

I definitely have 882photos in my folder, triple checked.

Questions:
My base is on a pole quite a bit up in the air. Its base was averaged over 30minutes and its the base I take my GCPs with. Do I need to add a height to it for PPK?
Why does it still say I don’t have enough photos?

1 Like

For completeness sake, I’m in Australia. Settings on my Emlid Gear:
BASE:


image
image

DRONE (M+)


image
image

I’d be happy to take a look using EzSurv, then we can at least see if this also occurs there, and if not, we might have a bug in Emlid Studio?

Link to all files here:

The above is in the Southern Folder. I’ve turned off editing as this is an open forum

Thank you, downloading. Do you have a base-location reference position, or just averaging a single?

You should find it in the RINEX header? I used a 30minute average 12months ago and keep reusing it.
I manually type in:
142.80779428E
-33.83469848N
83.930
Side Note: I’d be great if you could store multiple base locations :slight_smile: