Measuring voltage Servo Rail in mission planner

It is a 5 volt Ubec that is powering the servo rail.

Hi @Barry_Bolton,

Let’s try to sum up all the information we have for now on this topic as I’m getting confused and not sure I fully understand what are the difficulties you have at this stage.

Could you please clarify have you managed to display servo rails readings in QGC or MP?
What about USB port voltage readings? Can I ask you to elaborate on your hardware setup scheme? Some photos would be of much help.

Please use the following template when you describe the issue. This will help us a lot.

  1. Detailed problem description. How does observed behavior differ from the expected one?
  2. Your step by step actions.
  3. Picture of the setup and connection scheme.
  4. If using any additional hardware please provide exact make and model.

Please try to be as descriptive as it’s possible.

OK let em try again.

I use a 5 volt 3 amp UBEC to power the Navio2+ raspberry pi 3B+ when I am flying. The UBEC powers the whole set up via the servo rail

When bench testing I use a Raspberry pi power supply that I connect to the USB port of the Raspberry PI.

The output that is in the display of both Qgroundcontrol and Mission planner jumps around by as much as 2 volts every couple of seconds regardless of what is powering the Navio + raspberrypi. I used 4 s batteries and the voltage over a couple of seconds will vary from 14.6 volts to as much as 17 volts sometimes.

I will make a video about this and post it as well

Hi Barry,

May I ask you to advise whether you use the following power supply scheme?



Hi @Barry_Bolton,

As far as I understand, you’re trying to observe the voltage from the battery connected over Ubec to Servo rail. However, it’s not possible as servo rail always tries to maintain the voltage in 5V.

According to the servo rail measurements you posted earlier, I can suggest that:

  1. The voltage displaying is not correct as you haven’t configured the multiplier properly
  2. Voltage jumps are more likely provoked by Ubec

Well i managed to make a cable to use the Navio 2 battery port. However it is not the Ubec as the voltage also does the same when the USB is plugged in. I have measured the voltage directly from the ubec and the voltage is stable


We’ll try to reproduce such behavior with Ubec connected to the servo rail. I’ll write back to you once we have any updates.

Hi Barry,

We tried to replicate your power connection scheme and supplied the Navio2 with power over the Servo rail using Ubec:

We used the following settings in QGC:

And this setup seems to be working nicely. The voltage sometimes changes from 4.9 to 5V, however, it’s a normal behavior.

May I ask you to try the same multiplier as we tried? Is there anything we might miss in the setup?

OK mine is set up exactly like that but ill replicate what you have done there settings wise as well

Keep us posted.

Just flashing the SD and Ill let you know

OK those settings work


Glad to hear that.

Have you managed to figure out what was wrong with the previous setup?

Tatiana I think it is the highpower wifi extender cards that was causing power issues. I have had about 20 flights with no issue so far but I need a different frame so will rebuild and test further.

How far are you with making a USB bootable image?

Hi Barry,

We have considered adding this feature and at the moment we aren’t going to implement this.

It would be good as USB boot comes as standard with the RPI 3 B+

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.