Matrice 300 RTK and Emlid Caster

When setting up a custom network for the Matrice 300 RTK on the remote, I put in the credentials for the rover on Emlid Caster and I get RTK connected with the following message that never goes away and it blocks my RTK flight: RTK Connected. RTK data converging. I have tried several controlled areas, outside using hotspots, outside using hotspots and cellular, and inside using home wifi. Nothing resolves the “data converging” message. Any ideas on how to solve it? Do I need to adjust some settings from the base to create a stronger signal to the Matrice 300 controller. Also, the caution message is a “RTK weak signal” from DJI.

What is baseline length?

Correction Input from Baldwin City is 49km for the Base Station and less than 2 meters from the base station to my Matrice 300 rtk controller as the rover.

Can the Matrice receiver directly from the CORS via NTRIP? Or do you have to have a local base?

So you have a RS2 being corrected from a NTRIP service 49 km, and then you are using that RS2 to broadcast another correction-stream through the Emlid caster, right?

You can do it however you like. There is a USB dongle in the controller, that transmits the stream to the drone.

1 Like

I use RTK2go, I can not connect directly to it, it is possible I am doing something wrong. I am not an expert on these systems. I have a local base (RS2) that I am connecting to the Matrice 300. It actually makes a connection and shows coordinates and satellites, it just never gets past the converging data in the status area.

Yes, that is correct. Base has correction input from NTRIP and correction output using the Emlid Caster Mount Credentials. Lastly, I put the EMLID rover credentials on a separate RS2 for points and on the drone for precision measurements, mapping and etc., as needed for a job.

USB dongle? Are you talking about a 4G LTE dongle for cellular connection or something totally different. I have used a dongle, but I use a hotspot now for internet connection for the drone and the emlid RS2 base station.

You can also set a corrected point, setup the RS2 on it and cast directly from it. Or even LoRa if you have the capability.

That’s exactly what I am doing. I use the RS2 base station and cast from it, but for some reason, the Matrice 300 IS connecting to the RTK with the additional message, see below:

I am getting NTRIP correction on the input and casting out the Mount Point from Emlid Caster Mount Point and setting the Emlid Caster Rover credentials in the RTK of the drone (remote controller).

And it doesn’t matter if it is on the ground or in the air?

This message never ends, it never resolves, so I am unable to fly with RTK on, I have to turn it off to get the bird in the air, without RTK.

How is the environment around your take off site?

Directly outside my home, so I can do a test in a park area and get back to you on the results. But my RS2 gets a strong FIX with plenty of satellites. I live in a rural area, so just a home and land.

What firmware are you on? I had a friend that had that message that somehow got his hands on V03.00.0015 and it was fixed. I don’t know if it has been released to the public or not. This was back in December.

Wait, that is the firmware for the Matrice 300?..the most recent release is 2021.03.19 V02.02.03.01

My bad. I looked back and that was for the D-RTK 2. I don’t know what it resolved or it may have given a clue.

I have read a few firmware upgrade releases from DJI and one fix had to do with long RTK converging time when using Custom Network RTK. Apparently, it still is not fixed and I refuse to purchase the D-RTK-2, because I have two RS2 units. Are there any settings to change on the base station (RS2) that would make the communications better or stronger? This is my real question.

Yeah for sure. We tried the D-RTK 2 and coming from survey it is junk. Very inconsistent and cheaply made.

I am fairly new to NTRIP and Casting but I don’t see anything that can really change the strength/quality except the internet connection.