M2 does not always boot

Hello.
I am a user of a Uav mapping kit RS2 + M2 recently installed on a quadcopter. A simple integration has been done on the drone by connecting the VCC and GND pins of the C1 port to a Bec castle creations set to 5v which is capable of supplying up to 10a.

For days I see that the boot is not stable, always in the first flight of the day the system works in the first boot, but at the time that I disconnect it does not return to boot until after a few hours.

Previously I had integrated m+ in the same way and never had these problems.

Any idea what could be happening?

Hi @ALRC,

Welcome to the community forum!

Reach M2 has a bit stronger requirements for the power supply than Reach M+ does. You can check them in the Specification guide.

Could you specify if you checked the unit with another power supply? It’d be great if you could also elaborate on whether you checked other ports of your device.

M2 is powered by a Bec castle creations adjusted to 5.2V https://www.castlecreations.com/en/cc-bec-2-0-010-0154-00 is able to supply a large power capacity, so the demand of the reach m2 is perfectly covered (I think)

I have also tested on the C2 port, and USB and likewise it responds erratically, many times it does not turn on any leds and other cases (arbitrary) start perfectly. I could read that if only the orange power led turns on it could be a problem of low power supplied, but it is not the case because it has never happened.

Hi @ALRC,

Could you please clarify, did the M2 was powering up in such a way straight after the arrival? Also, do I get it right that you’ve tested that BEC when only M2 was powered up?

When I received the receiver it was working well, but in a matter of 10 flights it has started to work erratically.

There is another system that is also fed at 5v through the BEC (telemetry) is still working well, so I rule out an excess of voltage. Also despite the fact that the Bec feeds these two systems (m2 and telemetry) in no case is exceeded the amps that the bec can supply.

I have disassembled the M2 of the drone and in all the tests that I do both through the USB (2.1a usb supply) and through the S1 S2 C1 and C2 ports it behaves the same way. randomly it boots and works perfectly but mostly it doesn’t turn on any led and I have to cycle on/off again until I get it to turn on.

I don’t know what else to do

Hi @ALRC,

It would be really great if you could provide me with the hardware setup photos or a video. It will help to understand the setup better.

Yes, no problem.


M2 is powered through the C1 port, the red wire is 5v, black is GND and green is camera feedback.
Many m+ have been installed like this and there has never been a problem. This is our first integration with M2.

Hi @ALRC,

We’ve tested Reach M2 powered by JST-GH ports, including C1. It should work fine.

I can hardly help much with your specific hardware setup. However, please make sure your power supply meets Reach M2 requirements and provides 5V 600mA power.

In light of everything mentioned in the thread, it seems quite likely that either the M2 was damaged (power spike?, strange since Castle are high quality) during the 10 first flights, or it has a defect. Especially since it worked fine at first.

According to its specifications M2 needs 0.6 amps, the bec that provides can up to 10 amps so I rule out the problem of feeding.
Through the USB port it has the same reaction, sometimes it works correctly and other times it doesn’t even turn on the leds.

Hi @ALRC,

Is there any chance you can test Reach M2 with another power source? This will help us confirm that the issue is from the Reach’s side.

Yes, that test has been performed through other ports and USB (with another power source) and the behavior is the same

Is there any chance you have a multimeter to measure the output voltage when Reach M2 doesn’t boot?

yes, 5.1v in all cases

Did you measure current consumption?