M+/LORA radio link randomly dropping out

Hi there,

My Lora link keeps dropping out and I believe there is a fault with the M+/radio combo. I’m using the reach RS+ as a rover permanently fixed to a tractor, and the M+ with a Lora radio as a fixed base station on the roof of a shed. The M+ is always powered and all operations are line of sight and within 3km.

The link will work perfectly for a time (sometimes hours, sometimes days), and then there will not be any data transmitted from base. At first I thought there might be a frequency clash in my area, but after changing the frequency about 10 times I’ve ruled this out. I’ve also updated reachview on both units to 2.20.8 to no avail, and I’ve tried resetting both devices to default settings. I also wonder if heat could be a problem, as it gets to 40 degrees where we are, but the Lora link will also drop out randomly In the middle of the night in the cool.

Additionally, when the link cuts out, sometime the M+ can not be connected to by WiFi. It broadcasts the hotspot, but devices fail to connect… Kind of like it’s ‘frozen’. Also, at times when I have turned the M+ back on, an error message comes up saying Lora not connected (attached), even though it definitely is and works the majority of the time. Other times, the M+ just won’t transmit and there isn’t any error message.

Currently the only thing that gets me back to work is turn it off and on again and change the Lora frequency on both receivers.

Any ideas on how to diagnose the problem and how to fix?

Warm regards,

Josiah

Have you tried temporarily switching rover/base roles?

I have in the past, and the M+ works fine as a rover. Not sure if drops out over time, but it’s not really feasible for me to test. But I have isolated the problem as definitely at the M+ (left both units on overnight in the cool, woke up to no base corrections received on the ReachRS+, left it on, and turned the M+ off/on, and the reachRS started picking up correntions again), and seems to be the interaction between the M+ and the external LORA radio module. Even when the radio is transmitting, there is sometimes an error message saying LORA not connected.

The base (M+) stopped transmitting this morning. I downloaded a full system report straight away. May help?SystemReport.zip (451.8 KB)

Hi Josiah,

I’ve answered you over the email. Let me repeat it here.

Could you please share the logs from both receivers and the photos of the environment and your setup?

Hello, yes no problem.

Here is the rover (RS+):


Status from this morning:

Here is the base station (M+ with external Lora radio). I need a sicssor lift to get all the way up safely, but was able to take these photos. Basically, 240v AC to 5v power goes to S1, and the radio is plugged into S2. The radio is connected to a 8dbi omnidirectional aerial on the roof by short cable (total output about 26dbi accounting for loss), and the GNSS antenna is mounted on the roof of shed with a 20 by 30 stainless steel ground plane:




Status from this morning:

Environment. Turf farm:

Logs from base (I usually have logging turned off, so I’ve attached today’s logs and the logs from 21st December): solution_201912211310_LLH.zip (28.0 KB)
raw_201912211310_UBX.zip (1.0 MB)
solution_201912232224_LLH.zip (1.3 MB)

Rover logs. Same story. Today’s logs and one from October:
solution_201912232228_LLH.zip (853.8 KB)
base_201912232228_RTCM3.zip (1.5 MB)
solution_201910160555_LLH.zip (693.8 KB)
base_201910160555_RTCM3.zip (1.6 MB)

See of the raw files were too large to upload. Hope this is enough?
With the reduced bandwidth, it has been working without fault for 24 hours. But that is with no rinnex logs, which I would love to get back! Doesn’t make sense that bandwidth would be the problem to me. Radio should be able to cut it.

1 Like

Also, m+ saying no Lora radio currently, but it is actually transmitting.

Hi Josiah,

Thanks for such a thorough report!

Regarding the issue with the Wi-Fi connection, do I understand correctly that you can’t access the Reach M+ within your Wi-Fi network?

Regarding the issue with LoRa disconnection, may I ask you whether you have checked that the LoRa radio module is firmly attached and there are no loose cables? Have you checked if both modules (Reach M+ and LoRa) don’t overheat inside your mount case?

Have you had a chance to test several LoRa frequencies? Does the same issue happen with all of them?

Hi Polina,

No problem. At times, the M+ WiFi is being broadcast, but can not be connected to. When this happens, the solution is to turn power on and off again, and then I can connect fine.

Regarding LORA, there are no loose cables. And even if it was a faulty cable, I don’t think it fits. It works for days at a time, and the M+ is mounted in a waterproof container to a steel bracket. There is no movement or moisture that could aggravate a loose connection. Also, at the time I posted that photo of the M+/radio, the app was saying that the Lora module wasn’t connected, yet you can see in the photo that the radio power LED is lit, and that by luck I took the photo just as the blue TX LED was lit. Lora link was active during this time.

Not sure about overheating. How would I tell? Was hoping the systems report might show that. It does get to 45 degrees Celsius where we are, but the base station is in shade. And the m+ is rated to 65 degrees right? It has also malfunctioned in the night/early morning at about 25 degrees. What temperature is the Lora radio rated to?

I have tried many frequencies between 915.1MHz and 927.3MHz, and the issue is the same for all of them.

Hi and happy new year!

The issue is still occuring regularly. Sometimes within 3 hours or so of turning the base off and on again, and even with only the minimal RTCM messages for RTK being transmission.

Wondering of the possibility of the M+ and the lora radio being sent back to supplier for evaluation/diagnostic/repair/replacement?

Our supplier, Man goes mapping, Australia, said they are happy to replace the unit following confirmation from Emlid.

I believe we have also ruled out heat as a factor. This morning the base wasn’t transmitted and was restarted at 8:45am when it was 23 degrees Celsius. The base failed again by 11:45am which was 30.8 degrees. We restarted the base at 1pm when it was 34.5, and it is still operational during the heat of the day, 38 degrees.

Pending your investigation, I believe we’re dealing with a faulty unit (either the M+, the radio, or some combination). It’s becoming quite an inconvenience. What is the next step?

Hi Josiah,

Do I understand correctly that the rover and the base were not recording logs the last time the issue occured?

Would it be possible to upload the raw data logs from the previous tests to any file exchanger and post the link here? Only the raw data logs can give us information about the quality of the satellite reception on the rover. It’d be nice to take a look at them.

Also, may I ask you to generate the Full System Report on the rover and one more time on the base and send them to me in PM?

Hi Polina,

In the logs from the 24th of December, the issue didn’t occur. But from the earlier logs, it should have. It’s been happening very regularly. But I have left logging on, and I can send you more logs if needed?

No worries, here is UBX data from same dates as other logs for both receivers. https://drive.google.com/folderview?id=1CxM3TsLzyRobKJUmXcfxuwy_mN3zSZTy

I’m on site Monday, but I have PM’d you current system reports. 2 from the base (the more recent one definitely had a crash), and one from the rover. I’ll endeavour to get more system reports Monday, but yesterday, the base completely stopped. No lights, no life. Diagnosis on Monday.

Hi Josiah,

Thanks for the logs and for the reports!

I’ll look into them and contact you once anything is clear.

Please keep us posted on the base situation.

Hi Josiah,

How is it going? Was it possible to understand why Reach M+ base completely stopped?

Hi Polina,

Well, thanks. Apologies for the delay. I am moving back and forwards between the location of this setup and have been working through employees. As of this morning, the base is operating normally, and logs are recording on both the base and the rover.

We had a massive storm about a week ago, and the base plate was ripped off the roof. I have made a bracket and reinforced and replaced the tallysman antenna as it was destroyed.

Additionally, my 240V AC to 5V DC power supply also died, and this was the cause of the sudden loss of function 2 weeks ago. I have replaced and mounted the power supply in an electrical box at ground level, as I wonder if heat may be breaking this. This is the third power supply I’ve brought.

I have mounted the base station box a little lower in the shed, and cut ventilation holes. I have also removed the plastic case surrounding the M+ for better heat transmission. The plastic had warped from heat. From this morning, there is successful time sync and reachview launch. Everything is working fine and RTK corrections are being received by the rover.

My colleagues will continue to monitor, and I’m hopeful one or several of these improvements will help. Will keep you apprised. Were you able to spot anything in the system reports I sent you? Was the M+ or radio overheating etc? Heat stress doesn’t fit the pattern of when the base stops working (completely random, and in the cool of the night at times), but it’s a bit hard to argue with warped plastic.

Hi Josiah,

Thanks for the detailed update! Good to know everything works fine at the moment.

Your system reports do in fact show the significant heating of the Reach M+ which may result in abrupt shuts down of a radio link. Please, make sure your setup is ventilated properly and Reach M+ can cool out.

May I ask you to update your units to the last stable version v2.22.0? Please, test your setup with the new firmware.

If the issue occurs again, please, contact us straight away.

Hi Polina,

Thanks for this. 2nd day and still working fine. Ambient temperature got up to 40 degrees C, so far so good.

That’s very interesting to note. My current setup is now passively ventilated.

I will update the firmware ASAP and let you know of any problems.

1 Like