LTE modem

Hello, i have been using a router untill today to manage all my LTE connections to raspberry.

I want to try a 4G modem i have here, anybody can point me in the right direction to start reading and try to configure it?

I read somewhere that Panky is using a modem pratically plug and play, if i am that lucky and my modem is like that how can i see it?


huawei’s hilink modems are plug’n’play on raspberry pi;they behave like ethernet over usb!

Mine is this one:Huawei e3372

But if i plug it in, nothing works.


check if your settings on your modem are correct; your modem should have IP - there is a web interface where you can set it up; check it with your pc first if your modem connects to your provider;

On the pc it works but on raspberry when i plug it in and look at ifconfig i don’t see anything added.

The address on pc is


whats your output for lsusb?
(also update your stick to latest fw)

I’ll do it tomorrow and report back.

Any place to find correct firmware?


sudo apt-get update && sudo apt-get install usb-modeswitch
should resolve the issue if lsusb reports the stick is in mass storage mode; (i have a custom firmware on my e3372s-153 - but i believe that should work)

if it solves i should see a new interface in ifconfig?

yeah you’d see on eth0 or eth1

Thanks, what about stick firmware, any place to look for?


you’ll find an update button on the webui

Ah, ok thanks.

Done everything still no joy.

My webui doesn’t have an upgrade firmware option.


whats your output before and after usb-modeswitch installation from lsusb?

Same it didn’t change.

I even tried eject but didn’t do anything.

I think yesterday right after installing eject it chaged the ID in lsusb but than never changed again.


i dont know eject;
uninstall eject and usb-modeswitch,reboot and reinsert your modem and post the huawei line from lsusb (device id is not a personal information)

I know this may sound stupid but how do i uninstall eject and usbmodeswitch?


it’s not stupid
sudo apt-get remove usb-modeswitch
the same for eject but i don’t know it’s name

sudo apt-get remove ej (and double push “tab” to see what packages are installed beginning with “ej”)

Thanks, will do and let you know what lsusb says.