Loss of signal when UAV starts moving

I recently did some tests with the Reach attached to my UAV and the base station both gathering data independently for post processing. All data seems fine until the rover starts to move during takeoff, then I lose all satellite signal. I doubt that it is caused by interference from the drone because everything is fine when the rotors turn while the drone sits in place.

I’ve attached some pictures of my setup and screenshots of solutions and observation data.


Thanks for the detailed report.

From the log, it seems to be interference. Once a drone takes off, noise levels may grow and cause what we see in the raw log.

Please raise Reach antenna (https://docs.emlid.com/reach/antenna-placement/) (at least at the same level as GPS one) and use a bigger ground plane. It’s general recommendation from this section in our docs, that should help.

After Dmitriy replied, I looked closely at the picture and I see you have a bare antenna with no radome. I am sure I read somewhere that even slight wind currents over the antenna can cause problems. So another thing to try would be putting a plastic dome over the antenna top. Treat yourself to a dessert if you have to :slight_smile:


Thanks for these recommendations I’ll give it a try once I can fly again!

Meanwhile I tried to log raw data from both receivers to assess if I still had signal loss when I moved the tripods (to rule out interference from the drone). Weird things happened. While I walked with the receiver I always kept an eye on the reachview app to see if I had big variations in signal strength and if the solution passed from “single” to “-”, which it never did… all seemed fine until I converted the data in RTKconv. What I don’t understand is that the .obs files clearly indicate that there is a complete loss of signal for all satellites at certain times and I did not observe that while logging the data. The tripods were standing in really clear sky view but 30-40m from a parking lot (multipath involved?). Also, the fact that I was standing still or moving did not seem to affect the signal strength, it was always bad.

Here are some screenshots of my obs files and raw data.

Rover.zip (3.7 MB)

Hi, if you select the L1 og L1C from the dropdown menu (obs type) , you see there is signal all the way.
But you have cycle slips and in some of the files, alot of them. So you have some issues with the antenna.
Is this a different brand ? have you tried the antenna that came with the Reach package?
I would definitely put the antenna on a bigger groundplate.

I’ve done more tests this time with the rover antenna jacked 2 times as high as the the drone GPS and with a round ground plate of 8 inches of diameter. Signal is way better but I keep getting cycle slips and solution stays float for the most part with an AR ratio of 3.
Indeed my antennas are not the ones which came with the Reach they are Tallysman antennas bought separately at the time (2016) because they were supposed to give better results. They did give good results while testing last year but we did not use them for a year and that’s how it is now.

Also, note the initialization time for the base on the attached picture (signals were fluctuating for over 15 minutes then they all became stable).


Are the results the same with the orginal antenna? if you have it.

I can’t find the original antennas but I did order a brand new one (Tallysman TW2405) because I was convinced this was the problem. Did some really basic tests today, only collecting raw data from a stationary tripod and analyzing the RTKCONV results. I collected data with my new antenna as well as with the older one during two periods of the day. At first things looked better with the new one:

OBS with new antenna

OBS with both older antennas

But when I came back at the same spot during the afternoon I could not reproduce those results, they both seem to get lots of interference:
OBS with new antenna (2 files)

OBS with old antenna

I feel like I covered every possible source of error since there is not much parameter to change when collecting raw data for PPK (enable raw data logging, that’s all). My ground plane is a circle of aluminum 20 cm in diameter and my antenna is sticked to the center with duck tape. It feel like I’m missing something since every change I do (ground plane, antenna placement, firmware reflashing) doesn’t seem to change anything…

Just for reference, we had a weaker setup last year (ground plane 7 cm wide and rover antenna less than a feet from the drone) and we always had good results:

Could the reach module itself be the cause of poor signal reception? It seems to be the only thing I did not try to replace but I doubt it could affect the signal…

Do your reach share powersource with anything on the plane and what is the powersource?
Does the antenna cable pass any electronic device?
Could you check if the antenna mount on the reach is loose or has bad soldering?
Try unmount reach the uav/tripod and see if you experience the same then


I had a similar occurrence when using a Sik radio directly plugged into a Reach module. The satellite screen looked like an VU meter.

The powersource is a usb battery
The antenna is directly on top of the ground plane and reach hangs down from the plane
Both reach units experience the same kind of interference when placed in the same setup

Is it recommended to isolate the reach itself from RF noise or does it only affect the antennas? I wonder if the reach module is the cause. Whatever setup I come up with generates the same results (cycle slips on all satellites at the same time every 2 to 5 minutes).
I have ordered the UAV mapping kit in hopes that it solves the problem but I would still like to understand why it happens.

I recall @Simon_Allen mention noise as one major issue on his uav. I dont see why this couldnt be a problem with yours

1 Like

+1 Shield reach itself. Ground plane is not sufficient, reach need to be shielded …

It’s the wifi on the phantom, it cooks the reach unit unless you put it in a faraday cage.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.