LoRA stuck in Single Solution

Hi all,

I’ve been trying to get my Reach RS rover into fixed solution, but it’s stuck in Single.

Earlier, I selected a datum position by testing the base and rover to ensure I could get a fixed solution. After that, I followed the PPP docs to obtain the position of my base so I could manually enter the coodinates of the datum.

However I just can’t seem to even get a float solution from the datum location. I then tested it in other open locations and the rover just can’t get a float position. The rover is receiving corrections but not getting better than a single solution.

I’ve checked that the air rate and fequency settings were the same and I’ve changed these always ensuring that they were identical on both base and rover. I’ve also tried adjusting the GNSS, from GPS only and selecting an additional option (GLONASS etc) to see if that would make any difference.

I’ve also tried swapping LoRA antennae between the devices. Still no luck.

The Singal-to-noise ration shows Rover: 18 Base: 8. The coloured bars are all high and there are only four grey bars (G10-G32). No other grey bars are present.

The devices are on Reach firmware: 27 Beta 1, and I’m running Reachview 6.8 on Android.

Would anyone have some advice?

Thanks in anticipation.

Can you show us screenshot of this?

So, the screenshot brings up a Lot of questions :smiley:

How are you connected to your corrections? You mentioned LoRa, but you baseline length is over 30 km , suggestion that either:

  • you are receiving corrections over the internet via NTRIP, in which case you are much over distance-limit for Single Frequency receivers.
  • or you are indeed connected over LoRa, in which case you most likely have the wrong base-coordinate in your base.

I would also advice to enable all constellations on both receivers.

2 Likes

Hi Jerry,

Considering the thing that you previously were able to get the fixed solution just fine, my bet is that there is something wrong with the base coordinates.

The first thing I’d recommend is double-checking you entered them correctly. Also, you can share the PPP results and the RINEX file you used with us so that we can help with investigation :slightly_smiling_face:

1 Like

Hi @tatiana.andreeva and @wizprod,

I think that might be it! I entered the base coordinates from the NRCAN CRS PPP service directly as stated in the ITRF14 row! I’ll need to convert the ITRF14 to WGS84. As I’m new to this, could you recommend the best/most accurate/reliable way to convert ITRF2014 to WGS84 from the NRCAN PPP results?

Many thanks again :slight_smile:

The shift between the 2 should be in the centimeter level, if any, so I don’t think that is your problem.

1 Like

Drat.

Well, the base does not have any input corrections selected (off)… is there another setting to turn NTRIP off?

Hi Jerry,

I’m going to join Tatiana’s remark; it could be the case with the incorrectly entered coordinates. What happens if you set the base position obtaining to average SINGLE, for example? If the rover receives the corrections at the same setup, something is not right with the coordinates.

Maybe, there’s a minus sign missing in the manually entered coordinates. Can you please make sure the base coordinate is transmitted correctly? You can find what’s the base position in the Status tab on the rover.

Also, have you tried working with the survey projects in ReachView 3? The app supports different coordinate systems, so you don’t have to convert the coordinates from ITRF2014. If you select ITRF2014 for the project, you can enter the base coordinates in this system.

3 Likes

Hi @liudmila.slepova, @tatiana.andreeva and @wizprod,

Was just able to get out and give them and do another test run. Some good news: I was able to achieve Float and occasional Fix using the average single base location. I’ll have to play around with the LoRA frequency and satellite options to improve upon that.

So the problem, as you have correctly pointed out, was that I must have incorrectly entered the base coordinates. How should I enter them? I have reentered the ITRF2014 coordinates with the decimal after the degrees ITRF degrees… would you mind showing me what should be entered for the coordinates provided in the attachment?

Many thanks in anticipation.
UNC-base-raw_202107020321.pdf (1.2 MB)

No fix solution at all like this is very unusual, especially given the duration of the observation.

Can you post the raw-file (ubx if you have it, or otherwise the rinex)?

2 Likes

Thank you for the fast reply!
The Float and occasional Fix solution was achieved after an 6 sec average single run (only a quick test).

I’m hoping to use the base location from the PPP results to establish a site datum. I suppose I’m having difficulty entering the coordinates manually. Would you mind showing me how the attached NRCAN PPP coordinates should be entered into the manual base coordinates? (e.g. one decimal place vs degrees, minutes, seconds)? I’m a beginner at this :upside_down_face:

UNC-base-raw_202107020321_res.zip (4.9 MB)

ITRF14 (2021.5) -43° 25’ 54.62827" 146° 54’ 24.45405" -1.285 m <- convert from DMS to Decimal, also remember to transform to your native EPSG.

This is the position, however, it by no means precise or accurate! The height has 1+ m of standard deviation. With that duration of observation it should be 1 or less.

So, while you can use this position, it is no better than using average single!

Can you post the raw-file?

2 Likes

ITRF14 (2021.5) -43° 25’ 54.62827" 146° 54’ 24.45405" -1.285 m <- convert from DMS to Decimal, also remember to transform to your native EPSG.

I’m really sorry, but I don’t really understand. Would you mind posting how it would look as a converted DMS to decimal etc so that it could serve as an example?

Rinex file attached. Thanks again!
UNC-base-raw_202107020321_RINEX-2_11.zip (8.9 MB)


you can use i.e. this tool. What you get from NRCAN is DMS, you need Decimal.

I see now that it wasn’t a 6 day obs, but 6 hour obs. You might need significantly more on single-frequency receiver.
Don’t you have any CORS stations nearby?

2 Likes

Oh, I see! I thought I had read that observing for several hours would be sufficient. What would be a minimum amount of time for obs with a single frequency receiver?

Unfortunately no CORS stations nearby (over 100km away). The nearest datums/known points have canopy or power lines overhead. To the best of my knowledge, establishing my own datum via PPP is the only way for me to get reasonably accurate real world results. Any other suggestions are warmly welcomed :slight_smile:

I would say at least a day for your purpose as a reference for the future, preferably more.

However, I just tried processing your file in NRCAN myself.
It returned the error:
" Warning : Your dataset cannot be processed using ambiguity resolution (PPP-AR) because it only contains GLONASS data or single-frequency GPS data. No GLONASS products for ambiguity resolution are available at this time. For more information, please visit the CSRS-PPP update page"

Do you have the ubx file? Then we would try another conversion, using Rinex 3 instead. Not sure it would help, but worth trying.

2 Likes

I don’t have the UBX file. I will run obs for 24+ hours from my arbitrary datum point this evening. If single frequency cannot be used with the new NRCAN PPP-AR method, what process/output should I follow/obtain for optimal single frequency PPP results from NRCAN?

Also, are there any pro other tips that aren’t in the Emlid docs that I should follow to help run this long obs? e.g. keeping mobile device near the base receiver in a weather sealant container; turn off mobile device sleep function (keep screen active); turn off mobile bluetooth to save battery…

According to this, you can PPP single frequency data

2 Likes

Hi Jerry,

As Bryan correctly noted, you can use NRCAN CSRS-PPP to process the data from the single-band receiver. You can find the example of configuring the setting on Reach RS/RS+ for PPP logging in this guide.

If you’re going to leave Reach working for at least 24 hours, make sure that the receiver has enough battery level to run this long. You don’t need to keep the mobile device connected to Reach all the time. You can enable the logging and leave the receiver working. Whenever it’s required to check something, you can connect your mobile device to it.

2 Likes