LoRa high age of differential - M2 Base / R2 Rover

Hi everyone, Emlid newbie here. I could use help with getting LoRa working on some new equipment.
I’ve had an R2 since November, working decently well on NTRIP here in Northern California. But between long baselines and spotty cellular coverage, I could really my own base station.
I decided to go with an M2 and Beitian BT-300 antenna.
I can’t seem to get a stable connection, testing the setup in my backyard. I start with the default settings, adjust the base output settings so the gps corrections are transmitting at 1hz, I’ve tried a handful of LoRa frequencies. The R2 Rover shows as connected and receiving corrections, but the age of differential bounces from 3 seconds 30 seconds or longer.
I’m not quite sure how to trouble shoot or where to go next. Thanks!
(Cross posted to the facebook group)

What is your lora bit rate set to, and what messages are you sending at what interval?

9.11 kb/s, ARP at 0.1, MSM4s all at 1 Hz.

Increase to 18 kb/s and you should have no problems.

I’m thinking the problem may have more to do with the antenna or cable. I set it up for another test, and now the base can’t maintain float long enough for a two minute position average. It gets 10 to 30 seconds max, then blips to single, and the average resets. Do I need RTKlib to look at the antenna/receiver data?

Hi @deltakev,

Please try out these RTCM3 message combinations:

  • ARP 1006 0.1 Hz + GPS 1074 0.5 Hz + GLONASS 1084 0.5 Hz
  • ARP 1006 0.1 Hz + GPS 1074 0.5 Hz + Galileo 1094 0.5 Hz
  • ARP 1006 0.1 Hz + GPS 1074 0.5 Hz + Beidou 1124 0.5 Hz

If the age of differential rises, please record these logs for 10-15 minutes and send them to me:

  • raw data on the base and rover
  • base corrections on the rover
  • position on the rover
1 Like

Thank you for your help. I can receive corrections and get a fix using GPS + one other constellation as you suggested. As soon as I add another constellation the fix drops. I have the LoRa data rate set at 18 is wizprod suggested.
Is it a matter of the data overwhelming the LoRa bandwidth? It should be able to handle multiple constellations, especially at full speed shouldn’t it?

With this setting, you should have no problems running all constellations at 1 hz.
Is this happening in all locations? Think there could Radio interference that could lower the effective bitrate.

1 Like

This is a residential area. I haven’t tested it on a project site yet, as I wanted to make sure I had my setup working before taking it in the field.

The settings are limiting me to 902-928 mhz, and I’ve tried 905, 910, 915, and 925. Any time I select more than 2 constellations, it drops the connection. Even with 2, it gets unstable at 1 hz. It 0.5 it can keep the connection stable.

I’ve also tried both TCP on my local network, and Emlid Caster. Both connect successfully, with all constellations at 1hz.

What sort of range are you getting?

The base and receiver are within a few feet of each other.

Hi @deltakev,

We’ve reproduced the issue with the Reach M2 base, Reach RS2 rover and your RTCM3 message combination. We’re looking into the reasons with our devs, but it can take some time. You can stick to one of the RTCM3 sets I recommended for now.

1 Like

Thank you for the update. Is it too soon to know whether it’s firmware related? If so is there a process for rolling back to an earlier firmware version?

1 Like

Hi @kseniia.suzdaltseva ,

Since November 2021 I have reported this problem to support and to date with the 28.1 update they have not corrected it.

The only way to be able to use all the constellations is to keep the base on version 2.24.2, but this means not being able to use Reachview 3.

1 Like

Running Field Genius for android here with RS2 base/rover over LORA and I have also noticed a lot more “no-link” messages and greatly decreased radio range in the last couple of months. No settings have been changed on my end so am assuming its from a recent software update?

1 Like

Are you also running an M2 base, or is this on an RS2? Do both receivers need to be on the old firmware, or is your rover on the latest?

I could probably live with losing Reachview on the base, but I definitely need it on the rover.

Base M2 with old firmware and Rover M2 updated to 28.1, only then does LORA work well.

If you update the base M2 you will have the problems described. We hope Emlid finds the solution soon because this bug comes from the 2.24.2 update.

It should be noted that sending the corrections through NTRIP there are no problems if the Base is up to date.

That’s what I have found as well - NTRIP or TCP connections work fine, the problem is I would need a second internet connection for my base. Sending 2 constellations at 0.5 hz really isn’t going to work for me either, so I guess I’ll try to install the older firmware. Thank you @JAGUERO

I’m not seeing a way to roll back to old firmware versions. Is this not possible? I just purchased the M2, I’m not sure which version it shipped with, but it updated on first boot. My hope was there is a way to download an old version and manually install it.

Hi Jim,

We could catch the described issue only with the Reach M2 base. If you notice anything odd while working with a pair of Reach RS2, please write us at support@emlid.com. We’ll look into it separately.