Linking RS2 to Sontek M9 (ADCP)


Has anybody linked RS2 to Sontek M9?

We have bought it recently and there is a problem with linking…
Required output configuration should be:

38400 baud






I think the problem should be in NMEA output messages?
Any suggestions?

Hi Lado,

Just to understand the issue in more detail, what kind of issue do you have with this? Doesn’t the controller see the data from Reach?

Also, I think we need to check one thing straight away. If you require the NMEA messages to be output with 10 Hz, you need to have your GNSS Update rate (can be found in GNSS Settings tab) up to 10 Hz as well. This is just how the output settings work. Please make sure it’s so.

1 Like

Hi Polina,

Thank you for your attention.

I already solved mentioned issue.

The problem was that ADCP could not recognize GN messages, so I have searched and came across this topic: Reach Firmware 26 Update: Legacy RTCM3 Messages and NMEA Output Settings

Mentioned topic helped me to find where was Talker ID and switched from GN to GP, which solved my issue.

1 Like

Hi Lado,

Indeed, that’s also one of the most popular things :sweat_smile: From what I know, some equipment, mostly the one that’s been out for quite some time, has trouble with GN talker. That’s why we’ve added the option to change it, precisely.

Glad you can enjoy your experience with Reach fully now :slight_smile: If you have any questions, now we’re here to help!

Hi Lado,
Incidentally I am also integrating a RS2 to an M9.
We are using the long split cable to connect to the M9 and bypassing the PCM.
We are using the emlid round connector cable that terminates in a DB9. We cannot, however read any NMEA strings from the RS2 using Putty. Could there be a problem that it transmits UART and not rs232?
Im not entirely sure how UART and RS232 relates to eachother. If anyone could point us in the direction of a simple cable with some built in chip that would allow us to have data from the emlid in RS232 via a DB9 connector (pref female) Id be very happy :slight_smile:

Hi Daniel,

I can give you a bit of direction here. RS232 and UART protocols actually do have different voltage levels on their signals. That’s why you need to use an additional RS232-to-UART converter if you’re trying to get the data on the UART port. There are a few of them, I can’t really be more specific about them. Some are mentioned by our users here on the forum, so you can find them out.

The issue with the stream lies here, I believe: the port just doesn’t recognize the impulses from Reach. The converter should solve this issue. Please keep us in the loop on how it goes for you!

1 Like

Hi Polina, and thank you for the reply!
I’ve since writing read up more on UART and rs232 and found the voltages was different.
I was trying to find the pinouts for your connector but the pdf on your docs section is dead (especially keen on learning how to feed power to the reach from an external source).

But, do you mean that I need to convert your output to rs232? Or is the output from the reach rs232?
Every piece of equipment that I want to connect can read rs232 only.

Regards Daniel

Hi Daniel,

Indeed, thanks for noticing! We’re fixing the docs now, it may take some time. I’ll attach the connector’s pinout doc here so you can take a look at it. I’ll aslo add the pinouts for our cables from Store.

Oh, I though that you’re trying to connect to the UART port. That’s a more common case for DB9 connectors. The output from Reach’s external connector is RS-232. That’s why to connect it to UART, you need the converter.

Please double-check that the ports you’re using are RS-232. If it’s true and the steam is not established, we need to take a different approach. I’d start with checking the output format that is required on your device, maybe some of the messages are redundant. Let me know how it goes.

Sorry, forgot the actual files :joy: Here they are.

DB9.pdf (55.8 KB)
DB9F.pdf (57.0 KB)
RS232-port.pdf (977.9 KB)
without-connector.pdf (39.2 KB)

Hi Polina,
Thanks for the pinouts and reply!
I tried connecting via putty and just listening to the raw feed from the RS2, alas to no avail. It might be something simple such as I need to cross rs and tx (but I tried with a null modem, and without).
Another possibility is the serial ports on computers and rs232 to USB cables can be more or less useless. I’ve had consistently good results with converters running the ftdi chip, not this time.
Anyways, I think the issue is somewhere on my side, and I’m satisfied the Emlid indeed delivers rs-232. I’ll make sure to report back when I manage to interface the Emlid to our ADCPs!

Hi Daniel,

I’m glad to hear it! I think the pinout scheme can help with checking the wiring connection. Have you tried outputting the position via USB, just for a check? This way, we can see if the unit is capable of outputting the stream with the same settings.

Yes, both Bluetooth and USB will output positioning just fine.
I will fiddle around a bit more with serial adapters etc, next step if that doesn’t work is looking at the signal via an oscilloscope with the help of the pinout.
Thanks for all the help!


I see. True, I believe working with a multimeter or an oscilloscope will help to find the issue quicker. Be sure to keep us informed!

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.