Keep losing NTRIP corrections


I have a reoccuring issue with receiving NTRIP corrections. I went out to a big park yesterday in the middle of a city in order to try out the emlid (with its new simcard). I use the app “emlid flow” for this. It actually worked in the beginning and gave me corrections and the FIX icon showed on the display. However, i know by experience that it keeps losing corrections in unpredictable ways and i really do not know why. So, without changing anything, i rebooted the emlid and indeed it had lost the corrections. I waited for about 10 minutes until it had contact with about 37 satellites, but still no corrections. What is happening here? I need this to work for my job, but neither I nor my collegues are experts and I really need to speak to an expert now who can help me resolve this issue…

thanks in advance for any help i can get!


There are a lot of questions that I have here. First of all, have you tried using ntrip over Bluetooth with your mobile device versus the Sim card in the receiver? that would isolate whether the issue stems from the Sim card or the receiver. I am guessing the former. Second, do you have the same carrier for the Sim card as you do for the mobile device that you are connecting to the receiver? If so, how does the coverage look in that area? Lastly, are you under any canopy cover or up against any buildings? I am thinking that it has to do with the SIM card. Are you on the latest firmware? Also, is this a Reach RS+, RS2, RS 2+, or RX?


Thank you for your reply! Im working with an Emlid RS2+. The thought of experimenting with bluetooth somehow has occurred to me but im not sure how it works and what the benefits are. I can try it out though so i can answer your first question. Any advice on good tutorials?

The simcard on my phone comes from a different carrier (Telness) than the simcard in my receiver (Telia), however Telness uses Telias mobile network which is known to be the best carrier in the country. It most definitly provides coverage in the areas ive been testing the receiver lately, which in a open citypark with a good distance (about 50 meters) from the closest building.

Im using the app Emlid flow and have done the latest necessary updates. I also think it could be the simcard… which is why i ordered a new simcard for the receiver and tried it out a few days ago. The results i got from that are described in my first message… i got a fix to begin with, but lost it when i rebooted the receiver…

It weird right?

Hi Marjo,

Just to make sure I understand correctly, the receiver didn’t track any satellites for 10 minutes? Or did you just wait until it had more satellites in view?

Do you see the Waiting for corrections status in Emlid Flow when selecting NTRIP as corrections input?

Is the NTRIP mount point located within a 60 km range?


I just waited for more satellites hoping it would change the status “waiting for corrections”. When i looked at mount points it looked like the closest one was about 400 km away. I realize that this might be the problem

That is your problem.
For accurate, repeatable low 1-digit centimeter results, your baseline should be below 16 km.

alright, how do I change this? Any tutorials you can recommend?


Do you have a list of mount points that your NTRIP service provides? Usually, you should be able to check that with this service and choose the mount point that is the closest to you based on its location.

1 Like

There should be a list but I don’t have it at the moment. The receiver used to connect to the right mountpoint automatically (it´s a service we pay for) but not anymore for some reason. The list which emlid low shows only has three mountpoints to choose from, all 400 km away. I will look closer into this next week (wednesday) together with my boss. I’ll let you know how it went after.

Sure, I’ll wait for the news from you then!

So we have been investigating our problem without being able to solve it. We are still losing our corrections. The weird thing is that we do get a fix to begin with, but when we reboot it we lose our corrections completly. It even seems like it doesn’t even make an attempt to reconnect to the the Ntrip service. The only way we can make it work again is by turning it off and wait for about 20 minutes. We called our Ntrip provider who could confirm that we had been connected to their service twice, not four times. This means that once we reboot our emlid it loses capability to reconnect to our Ntrip service. What is going on here? Why does the emlid need to be turned off for such a long time?

Thanks in advance for any help we can get!


Hi Marjo,

Is the status remains SINGLE at these moments after reboot? Have you changed the mount point to the one within the 60 km?

Right now it looks like there’s an issue with the internet connection. The receiver doesn’t get a stable connection after the reboot, so it can’t receive the corrections right away. Does the receiver get an internet connection from the SIM card as you mentioned earlier?

1 Like

Yes it says SINGLE after reboot. It does say FIX before reboot though. The points we measure when it says FIX are correct and the emlid is connected to a mountpoint within 6 km then. We know this because we could see the coordinates of the mountpoint in the measurements information. The app itself (EmlidFlow) does still not show an extensive list of mountpoints though. Only 4 ones that say they are 400 km away…

And yes, we could confirm on our phones that the receiver got 4G/LTE connection from its SIMcard

We have now come to the conclusion that the best way of avoiding to lose corrections is by simply not turning the receiver off during the day. The battery has a strong battery that keeps going for a full day. The best thing is to simply wait to turn it off until everything for the day is done and then charge it during the night.


A post was split to a new topic: RS2 solution status constantly jumps between SINGLE and FIX

Hi Marjo,

Sorry for the delayed reply!

You may share a Full system report from the receiver with me and we’ll check if there’s anything wrong on the receiver’s side. Please send it to as it contains sensitive data.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.